Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 24692 - rpm-4.0.1 database problem
rpm-4.0.1 database problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-23 09:16 EST by benedict
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-23 09:16:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description benedict 2001-01-23 09:16:32 EST
I install rpm-4.0.1 on a host running 4.0,.
then, I go back to 4.0
then, I try going to 4.0.1 again - and I get a core-dump from 4.0 ...

[root@beast /root]# cd /users/src/install/
[root@beast install]# rpm.daimi -U
/users/src/install/RPMS/i386-none-Linux/rpm-4.0.010118-1.rpm
/users/src/install/RPMS/noarch-none-noos/rpm-shr-4.0.010118-1.rpm
[root@beast install]# rpm.daimi -U
/users/src/install/RPMS/i386-none-Linux/rpm-4.0-3.rpm
/users/src/install/RPMS/noarch-none-noos/rpm-shr-4.0-3.rpm --oldpackage 
[root@beast install]# rpm.daimi -U
/users/src/install/RPMS/i386-none-Linux/rpm-4.0.010118-1.rpm
/users/src/install/RPMS/noarch-none-noos/rpm-shr-4.0.010118-1.rpm
Segmentation fault (core dumped)
Comment 1 Jeff Johnson 2001-03-16 14:13:00 EST
Yup. What's happening is that rpm-4.0.[12] does not sort tags in the database.
When you
go back to rpm-4.0, a "must have" tag (i.e. there's no attempt to check that a
pointer
is NULL) causes a segfault. rpm-4.0.2 is both the cause and the solution,
otherwise
the end of headerLoad() needs modification so that tags are sorted when loading:
	h->sorted = 1;
	

Note You need to log in before you can comment on or make changes to this bug.