Bug 24704 - X11 modes are the same for all clock frequencies
Summary: X11 modes are the same for all clock frequencies
Status: CLOSED DUPLICATE of bug 24462
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-23 16:56 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 06:43:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The description from http://florida.linuxusers.org/howto/hi-res/ (9.27 KB, text/html)
2001-02-07 06:43 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-01-23 16:56:39 UTC
The generated modes in XF86Config
(Modeline ...)
seems always the same, for all videocards.
The problem is that possible dot-clock frequencies
for the videocars chip are different 
for different videocards, so some
high-resolution modes are not available with generated config 
despite the videocard can perfectly support 
such high frequency and resolution.
This requires manual adjustment of "Modeline... " to get high
frequency/resolution modes working.

The improvement which need to be done is the following:
read all possible chip clocks from the videocard
(XFree86 Rel 4 server prints them to stderr)
and then generate modes based on available 
chip clocks. This way the the generated modes
will have the clocks supported by the videocard
and thus the best supported mode can be used by X server.

Comment 1 Need Real Name 2001-02-07 06:37:28 UTC
See http://florida.linuxusers.org/howto/hi-res/
for information how to do this.

Also this bug is related to
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=24462

Comment 2 Need Real Name 2001-02-07 06:43:51 UTC
Created attachment 9199 [details]
The description from http://florida.linuxusers.org/howto/hi-res/

Comment 3 Preston Brown 2001-02-08 19:53:24 UTC

*** This bug has been marked as a duplicate of 24462 ***


Note You need to log in before you can comment on or make changes to this bug.