Bug 24705 - Error during kernel compile
Summary: Error during kernel compile
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-23 17:20 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-25 04:34:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-01-23 17:20:05 UTC
Attempting to compile kernel  2.2.16
modutils -2.3.21, gcc-2.96-69 .  Pentium 233 , 64 M

make -C netlink fastdep
make[4]: Entering directory `/usr/src/linux/net/netlink'
/usr/src/linux/scripts/mkdep af_netlink.c netlink_dev.c > .depend
make[4]: Leaving directory `/usr/src/linux/net/netlink'
make -C sched fastdep
make[4]: Entering directory `/usr/src/linux/net/sched'
/usr/src/linux/scripts/mkdep cls_api.c cls_fw.c cls_route.c cls_rsvp6.c
cls_rsvp.c cls_rsvp.h cls_u32.c estimator.c police.c sch_api.c sch_cbq.c
sch_csz.c sch_fifo.c sch_generic.c sch_prio.c sch_red.c sch_sfq.c
sch_tbf.c sch_teql.c > .depend
make[4]: Leaving directory `/usr/src/linux/net/sched'
make -C packet fastdep
make[4]: Entering directory `/usr/src/linux/net/packet'
/usr/src/linux/scripts/mkdep af_packet.c > .depend
make[4]: Leaving directory `/usr/src/linux/net/packet'
make -C sunrpc fastdep
make[4]: Entering directory `/usr/src/linux/net/sunrpc'
/usr/src/linux/scripts/mkdep auth.c auth_null.c auth_unix.c clnt.c
pmap_clnt.c sched.c stats.c sunrpc_syms.c svcauth.c svcauth_des.c svc.c
svcsock.c sysctl.c xdr.c xprt.c > .depend
make[4]: Leaving directory `/usr/src/linux/net/sunrpc'
make -C econet fastdep
make[4]: Entering directory `/usr/src/linux/net/econet'
/usr/src/linux/scripts/mkdep econet.c > .depend
make[4]: Leaving directory `/usr/src/linux/net/econet'
make -C irda fastdep
make[4]: Entering directory `/usr/src/linux/net/irda'
/usr/src/linux/scripts/mkdep af_irda.c crc.c discovery.c irda_device.c
iriap.c iriap_event.c irias_object.c irlap.c irlap_comp.c irlap_event.c
irlap_frame.c irlmp.c irlmp_event.c irlmp_frame.c irmod.c irproc.c
irqueue.c irsysctl.c irttp.c parameters.c qos.c timer.c wrapper.c >
.depend
make _sfdep_irlan _sfdep_ircomm _sfdep_compressors
_FASTDEP_ALL_SUB_DIRS="irlan ircomm compressors"
make[5]: Entering directory `/usr/src/linux/net/irda'
make -C irlan fastdep
make[6]: Entering directory `/usr/src/linux/net/irda/irlan'
/usr/src/linux/scripts/mkdep irlan_client.c irlan_client_event.c
irlan_common.c irlan_eth.c irlan_event.c irlan_filter.c irlan_provider.c
irlan_provider_event.c > .depend
make[6]: Leaving directory `/usr/src/linux/net/irda/irlan'
make -C ircomm fastdep
make[6]: Entering directory `/usr/src/linux/net/irda/ircomm'
/usr/src/linux/scripts/mkdep ircomm_core.c ircomm_event.c ircomm_lmp.c
ircomm_param.c ircomm_ttp.c ircomm_tty_attach.c ircomm_tty.c
ircomm_tty_ioctl.c > .dependmake[6]: Leaving directory
`/usr/src/linux/net/irda/ircomm'
make -C compressors fastdep
make[6]: Entering directory `/usr/src/linux/net/irda/compressors'
/usr/src/linux/scripts/mkdep irda_deflate.c > .depend
make[6]: Leaving directory `/usr/src/linux/net/irda/compressors'
make[5]: Leaving directory `/usr/src/linux/net/irda'
make[4]: Leaving directory `/usr/src/linux/net/irda'
make[3]: Leaving directory `/usr/src/linux/net'
make[2]: Leaving directory `/usr/src/linux/net'
make -C ipc fastdep
make[2]: Entering directory `/usr/src/linux/ipc'
/usr/src/linux/scripts/mkdep msg.c sem.c shm.c util.c > .depend
make[2]: Leaving directory `/usr/src/linux/ipc'
make -C lib fastdep
make[2]: Entering directory `/usr/src/linux/lib'
/usr/src/linux/scripts/mkdep ctype.c errno.c inflate.c string.c
vsprintf.c > .depend
make[2]: Leaving directory `/usr/src/linux/lib'
make -C arch/i386/kernel fastdep
make[2]: Entering directory `/usr/src/linux/arch/i386/kernel'
/usr/src/linux/scripts/mkdep apm.c bios32.c bluesmoke.c entry.S head.S
i386_ksyms.c init_task.c io_apic.c ioport.c irq.c irq.h ldt.c mca.c
mtrr.c process.c ptrace.c setup.c signal.c smp.c sys_i386.c time.c
trampoline.S traps.c visws_apic.c vm86.c > .depend
make[2]: Leaving directory `/usr/src/linux/arch/i386/kernel'
make -C arch/i386/mm fastdep
make[2]: Entering directory `/usr/src/linux/arch/i386/mm'
/usr/src/linux/scripts/mkdep extable.c fault.c init.c ioremap.c >
.depend
make[2]: Leaving directory `/usr/src/linux/arch/i386/mm'
make -C arch/i386/lib fastdep
make[2]: Entering directory `/usr/src/linux/arch/i386/lib'
/usr/src/linux/scripts/mkdep checksum.S delay.c getuser.S old-checksum.c
putuser.S semaphore.S usercopy.c > .depend
make[2]: Leaving directory `/usr/src/linux/arch/i386/lib'
make[1]: Leaving directory `/usr/src/linux'
[root@box1 linux]# make bzImage
cc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -D__SMP__ -pipe
-fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2
-malign-functions=2 -DCPU=586  -c -o init/main.o init/main.c
cc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -D__SMP__ -pipe
-fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2
-malign-functions=2 -DCPU=586 -DUTS_MACHINE='"i386"' -c -o
init/version.o init/version.c
make -C  kernel
make[1]: Entering directory `/usr/src/linux/kernel'
make all_targets
make[2]: Entering directory `/usr/src/linux/kernel'
cc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -D__SMP__ -pipe
-fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2
-malign-functions=2 -DCPU=586   -DEXPORT_SYMTAB -c signal.c
cc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -D__SMP__ -pipe
-fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2
-malign-functions=2 -DCPU=586   -DEXPORT_SYMTAB -c ksyms.c
cc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -D__SMP__ -pipe
-fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2
-malign-functions=2 -DCPU=586   -fno-omit-frame-pointer -c -o sched.o
sched.c
cc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -D__SMP__ -pipe
-fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2
-malign-functions=2 -DCPU=586   -c -o dma.o dma.c
cc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -D__SMP__ -pipe
-fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2
-malign-functions=2 -DCPU=586   -c -o fork.o fork.c
cc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -D__SMP__ -pipe
-fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2
-malign-functions=2 -DCPU=586   -c -o exec_domain.o exec_domain.c
exec_domain.c: In function `register_exec_domain':
exec_domain.c:83: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [exec_domain.o] Error 1
make[2]: Leaving directory `/usr/src/linux/kernel'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/usr/src/linux/kernel'
make: *** [_dir_kernel] Error 2

Comment 1 Arjan van de Ven 2001-01-23 19:12:06 UTC
You need kgcc to compile 2.2 kernels.

Comment 2 Need Real Name 2001-01-24 04:08:15 UTC
kgcc-1.1.2-40 is installed.

Comment 3 Need Real Name 2001-01-24 09:22:25 UTC
I changed the line in Makefile to use kgcc and am now getting Signal 11 errors.  Is it possible to compile a kernel on another machine and then transfer 
it over to this machine.

Comment 4 Arjan van de Ven 2001-01-24 09:49:07 UTC
Yes
But signal 11 in random places usually is an indication of hardware failure 
(often bad ram chips). You can test your ram with the memtest86 program.

Comment 5 Need Real Name 2001-01-25 04:34:20 UTC
I think this can be closed out because I am getting signal 11 and signal 4 errors on repeated compiles.  This would be indicative of a hardware problem.  I 
think that we resolved the initial problem, which was that the line in the Makefile needed to be changed to use the kgcc.

Comment 6 Karsten Hopp 2001-02-09 14:42:21 UTC
Closed as suggested by reporter


Note You need to log in before you can comment on or make changes to this bug.