Bug 247113 - Bad Provides
Bad Provides
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mrtg (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-07-05 10:14 EDT by Michael Schwendt
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.15.1-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 22:30:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2007-07-05 10:14:27 EDT
There are bad Perl package "Provides" in mrtg:

https://www.redhat.com/archives/fedora-perl-devel-list/2007-July/msg00012.html

> mrtg provides perl(SNMP_util) EQ 0 1.08
> perl-SNMP_Session provides perl(SNMP_util) EQ 0 1.06
>  required by: perl-SNMP_Session - 1.08-3.fc6.noarch
> 
> mrtg provides perl(SNMP_Session) EQ 0 1.08
> perl-SNMP_Session provides perl(SNMP_Session) EQ 0 1.08
>  required by: perl-SNMP_Session - 1.08-3.fc6.noarch
>  required by: mrtg - 2.15.1-2.fc7.i386
> 
> mrtg provides perl(BER) EQ 0 1.05
> perl-SNMP_Session provides perl(BER) EQ 0 1.05
>  required by: perl-SNMP_Session - 1.08-3.fc6.noarch
>  required by: mrtg - 2.15.1-2.fc7.i386
Comment 1 Chris Adams 2007-08-14 14:58:26 EDT
I just ran into this because yum will prefer mrtg as a source for
perl(SNMP_Session) over the real source, perl-SNMP_Session.  This leads to
broken installs of RPMs that use the modules from perl-SNMP_Session.

This needs to be fixed ASAP since it leads to broken programs.
Comment 2 Michael Schwendt 2007-09-19 18:57:13 EDT
Do you need help? This bug is still present in rawhide, too.
Comment 3 Vitezslav Crhonek 2007-09-20 05:25:08 EDT
Sorry for the delay, it's fixed in F-7 and rawhide now.
Comment 4 Fedora Update System 2007-09-24 14:00:20 EDT
mrtg-2.15.1-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-10-08 11:03:25 EDT
mrtg-2.15.1-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Chris Adams 2007-10-11 20:56:32 EDT
It is still claiming to provide a bunch of perl modules that aren't really
installed for the system (they are all in a private MRTG directory).  The
following two are provided (for real) by perl-SNMP_Session:

  perl(SNMPv1_Session)  
  perl(SNMPv2c_Session)  

I _think_ the rest of the provides are probably harmless (because they don't
appear to overlap any real modules).
Comment 7 Fedora Update System 2007-10-17 22:27:58 EDT
mrtg-2.15.1-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mrtg'
Comment 8 Fedora Update System 2007-11-14 22:30:07 EST
mrtg-2.15.1-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.