Bug 247119 - Request: Disk Druid support for installation on RAID-1 degraded array
Request: Disk Druid support for installation on RAID-1 degraded array
Status: CLOSED DUPLICATE of bug 188314
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 10:59 EDT by Gerry Reno
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 11:24:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerry Reno 2007-07-05 10:59:13 EDT
I have been using a technique that at least for me greatly simplifies moving 
to and from RAID-1 on any system.  I do this by installing the system on a 
degraded RAID-1 array and then later it is very simple to make the system true 
RAID by just adding the missing drive/partitions.

 In Disk Druid I would like to see the ability to install on a degraded RAID-1 
array where I declare RAID-1 but then the second mirror is missing.  I install 
this way all the time on systems and then when I add the second hard drive 
later and place it into the array, it just syncs.  Want to go back to just a 
single drive - no problem.  Just fault the device and remove it.  No 
complicated remounting filesystems or anything - very smooth.  This way you're 
always on an md device.  I would like to see this actually become the default.  
It makes it very easy to convert a system to RAID-1 later on if the user would 
like to do so without any complicated procedures necessary.
Comment 1 Gerry Reno 2007-07-08 15:09:21 EDT
Just to clarify our setup.  We establish the degraded RAID-1, let's say
/dev/md0, and then we use this device as an LVM physical device and layer LVM
over the RAID. Then we mount an LVM logical device (eg:
/dev/mapper/VolGroup00-LogVol00) containing the root (/) filesystem.  The point
being that the degraded RAID-1 is no different than using any other RAID device
to form a filesystem mounting solution.
Comment 2 Peter Jones 2007-07-09 11:24:19 EDT

*** This bug has been marked as a duplicate of 188314 ***

Note You need to log in before you can comment on or make changes to this bug.