Bug 247156 - RFE: yum grouplist and friends
RFE: yum grouplist and friends
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
420
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Pazdziora
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 13:39 EDT by Thorsten Scherf
Modified: 2010-10-12 16:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat501
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 11:32:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2007-07-05 13:39:33 EDT
Description of problem:
yum grouplist does not work when running against rhn satellite. when will this
code get into satellite?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Brandon Perkins 2007-07-06 16:09:57 EDT
This works in hosted, but not against satellite...not sure how this was missed.
Comment 2 Brandon Perkins 2007-07-06 16:15:18 EDT
Reassigning to Shannon.
Comment 3 Brandon Perkins 2007-07-06 16:43:17 EDT
More info...

=== error_log ===
Exception exceptions.ValueError: 'I/O operation on closed file' in <bound method
File.__del__ of <rhn.transports.File instance at 0xb75b040c>> ignored

=== access_log ===
10.10.76.185 - - [06/Jul/2007:16:41:24 -0400] "POST /XMLRPC HTTP/1.1" 200 901
"-" "rhn.rpclib.py/$Revision: 102540 $"
10.10.76.185 - - [06/Jul/2007:16:41:24 -0400] "POST /XMLRPC HTTP/1.1" 200 1256
"-" "rhn.rpclib.py/$Revision: 102540 $"
10.10.76.185 - - [06/Jul/2007:16:41:24 -0400] "GET
/XMLRPC/GET-REQ/rhel-i386-server-5/repodata/repomd.xml HTTP/1.1" 200 1239 "-"
"urlgrabber/3.1.0"

Comment 6 Jan Pazdziora 2007-07-18 12:53:23 EDT
It looks like hosted supports group* operations because it known about the comps
file, which gets pushed to the rhn.redhat.com by releng.

adelton | jbowes: I'm working on comps support for Satellite.
adelton | jbowes: Could you confirm to me that the comps file is never (not even
on hosted) generated from the database, but is just a file on the filesystem?
jbowes  | adelton: correct
adelton | jbowes: So to add the support to the Satellite, I'd better fix
satellite-sync to get it from hosted and store somewhere (and the existing logic
in the Satellite should kick in just fine, right)?
adelton | jbowes: (existing logic to serve it to yum)
jbowes  | adelton: right
adelton | jbowes: Soooo ....
adelton | jbowes: What's the best place to store it? Where do you store it in
hosted?
adelton | jbowes: /var/satellite/comps?
jbowes  | adelton: it jsut gets uploaded like the isos, so anywhere releng wants
to put it
Comment 15 Jan Pazdziora 2007-07-23 15:08:07 EDT
(In reply to comment #7)
> figure out how to support this in the Satellite? It looks like the comps file is
> in the /var/satellite/rhn/kickstart tree ... but that only gets populated with
> RHN Tools child channels, not with the parent channel. So it won't work 100 per

This is not correct. The kickstart tree comes with the parent directory, and it
contains comps*.xml for all the standard RHEL child channels (see comment #12).

However, for additional child channels we probably won't get the comps*.xml at all.
Comment 20 Jan Pazdziora 2007-07-25 04:44:46 EDT
Fix committed to SVN, branch RELEASE-5.0, revision 118568, and trunk, revision
118569.
Comment 21 Jan Pazdziora 2007-07-27 05:55:35 EDT
Added try ... except IOError to SVN, revisions 118665 and 118666.
Comment 22 Jan Pazdziora 2007-08-02 16:36:38 EDT
Moving ON_QA because:

Satellite 5.0.1-1 and Proxy 5.0.1-1 are now available on webqa hosted
channels.  Satellite 5.0.1-1 ISOs are now available.
Comment 23 John Ha 2007-08-02 17:05:59 EDT
Does this issue need an entry in the Satellite 501 release notes? Something
along the lines of the following? Let me know if it needs to go into the notes.
Thanks!

 The 'yum grouplist' command now properly lists groups when run on a machine
 registered to Red Hat Network Satellite.
Comment 24 Jan Pazdziora 2007-08-03 09:29:58 EDT
(In reply to comment #23)
> 
>  The 'yum grouplist' command now properly lists groups when run on a machine
>  registered to Red Hat Network Satellite.

  Yum's group operations now work correctly on a machine registered to RHEL 5
  channels on Red Hat Network Satellite.

We did a nasty hack to only enable the group functionality for RHEL 5 channels,
and all group operations should now work, not just grouplist.
Comment 25 Brandon Perkins 2007-08-03 14:50:45 EDT
Verified with the understanding of the hardcoding/limitations for 5.0.x. 
Related bug entries look to cover those cases well, so I'm happy to mark this
verified for 5.0.1.
Comment 26 Brandon Perkins 2007-08-22 21:27:50 EDT
Release Pending.
Comment 28 Thorsten Scherf 2008-04-10 02:57:42 EDT
which release has the fix included?
Comment 29 Thorsten Scherf 2008-04-10 02:59:36 EDT
talking about 4.2 releases.

Note You need to log in before you can comment on or make changes to this bug.