This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 247191 - NetworkManager triggers hang bug in bcm43xx driver
NetworkManager triggers hang bug in bcm43xx driver
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 17:04 EDT by Robin Green
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version: b43
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 16:53:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2007-07-05 17:04:23 EDT
Description of problem:
I am using the bcm43xx driver because the newer driver for the same chipset did
not work at all for me. When NetworkManager is running, the wireless network
connection eventually dies, and then the driver gets stuck with a repeated
message "bcm43xx: IRQ_READY timeout" in dmesg. When I disable NetworkManager
using ntsysv, reboot, and just use service network (re)start, the wireless
connection still dies after a while, but the bcm43xx driver does not get stuck
and I can still bring the connection back up.

Version-Release number of selected component (if applicable):
NetworkManager-0.6.5-5.fc7

How reproducible:
Always

Steps to Reproduce:
1. Using knetworkmanager or the network configuration tool, try to activate
wlan0. Repeat until you succeed.
2. Do nothing.
3.
  
Actual results:
After some period of time, the network goes down, the radio is switched off and
the WLAN light on the case goes off. After the first or second time this happens
(it varies), it is not possible to restart the network, short of a reboot.

Expected results:
Should be possible to bring the network back up

Additional info:
It looks pretty obvious that the driver somehow gets into a state whereby it
thinks it should be receiving IRQs from the device, but the device is not even
listed in /proc/interrupts any more, presumably because it is switched off.
Beyond that, I couldn't figure it out. What would you like me to attach? This is
very reproducable.
Comment 1 Christopher Brown 2007-09-17 16:34:25 EDT
Hello Robin,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 2 Robin Green 2007-09-17 16:53:50 EDT
The new driver, b43, now works for me, so I don't need to use the old bcm43xx
driver.
Comment 3 Christopher Brown 2007-09-17 16:58:48 EDT
Great news Robin. I've adjusted the resolution slightly to reflect what worked
for you.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.