Bug 247199 - Customizing software selection crashes Rhel4 u6 installer
Customizing software selection crashes Rhel4 u6 installer
Status: CLOSED DUPLICATE of bug 246653
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 17:43 EDT by George Beshers
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-06 15:50:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Beshers 2007-07-05 17:43:12 EDT
Description of problem:
  I was testing the NFS installation of rhel4-u6 on altix4.rhts
  (dual 330).  During a normal install (firewall disabled, selinux disabled,
  and setting the system clock to UTC --- I think thats what I did
  both times) after selecting "customize software" and advancing to
  the next page I got:

7/5 from bigpapi:rhel4-u6-ia64-AS
This was altix4 (dual 330) with the SCSI vault turned off.

Making this a BZ -- this is RedHat's problem.

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1186, in ?
    intf.run(id, dispatch, configFileData)
  File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/text.py", line 488, in run
    rc = apply(win, (self.screen, ) + args)
  File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/textw/packages_text.py", l
ine 49, in __call__
    (parlist, pardict) = orderPackageGroups(grpset)
  File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/hdrlist.py", line 971, in
orderPackageGroups
    compsParents = grpset.compsxml.hierarchy.order
AttributeError: 'dict' object has no attribute 'order'

> /var/tmp/anaconda-10.1.1.63/usr/lib/anaconda/hdrlist.py(971)orderPackageGroups
()
-> compsParents = grpset.compsxml.hierarchy.order
(Pdb)


Check for related patches 	
7/5 from bigpapi:rhel4-u6-ia64-AS

Version-Release number of selected component (if applicable):
  7/5 from bigpapi:rhel4-u6-ia64-AS


How reproducible:
  twice -- didn't try further

Steps to Reproduce:
1. NFS install
2. disable firewall, selinux
3. set UTC
4. request customize software
5. hit contiue
  
Actual results:
  backtrace shown above


Expected results:
  successful install


Additional info:
Comment 1 Jeremy Katz 2007-07-06 15:50:01 EDT

*** This bug has been marked as a duplicate of 246653 ***

Note You need to log in before you can comment on or make changes to this bug.