Bug 247209 - rhcs7.3 7.2 7.1 DOC Error - 4.9.4.1. Log File Rotation - 2592000 seconds is 1 month
rhcs7.3 7.2 7.1 DOC Error - 4.9.4.1. Log File Rotation - 2592000 seconds is 1...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Certificate System
Classification: Red Hat
Component: Doc - administration-guide [RED HAT] (Show other bugs)
7.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Deon Ballard
Chandrasekar Kannan
: Documentation
Depends On:
Blocks: 251848 450578
  Show dependency treegraph
 
Reported: 2007-07-05 20:34 EDT by Issue Tracker
Modified: 2017-04-10 10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 23:02:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2007-07-05 20:34:33 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2007-07-05 20:34:36 EDT
The on-line documentation for CS7.1 and CS7.2 have an error. Please see this URL for CS7.1

http://www.redhat.com/docs/manuals/cert-system/admin/7.1/basics.html#32345

The specific section states:

Log File Rotation

Log files are rotated when either of the following occur:

    * The size limit for the corresponding file is reached-the size of the corresponding log file is equal to or greater than the value specified by the maxFileSize configuration parameter. The default value for this parameter is 100 KB.
    * The age limit for the corresponding file is reached-the corresponding log file is equal to or older than the interval specified by the rolloverInterval configuration parameter. The default value for this parameter is 2592000 seconds (every hour). 

The error is with the last statement.  The value of 2592000 seconds corresponds to one month - not one hour.

Please see this URL for CS7.2:

http://www.redhat.com/docs/manuals/cert-system/admin/7.2/Administrative.Basics.34201.html#Administrative.Basics.32345

The specific section states:

3.9.4.1. Log File Rotation

Log files are rotated when either of the following occur:

    *

      The size limit for the corresponding file is reached. The size of the corresponding log file is equal to or greater than the value specified by the maxFileSize configuration parameter. The default value for this parameter is 100 KB.
    *

      The age limit for the corresponding file is reached. The corresponding log file is equal to or older than the interval specified by the rolloverInterval configuration parameter. The default value for this parameter is 2592000 seconds (every three days).

The error is with the last statement.  The value of 2592000 seconds corresponds to one month - not three days.
This event sent from IssueTracker by msauton  [SEG - Certificate System Engineering]
 issue 109261
Comment 2 Thomas Kwan 2007-07-09 13:41:10 EDT
Target Fix 8.0
Comment 3 David O'Brien 2007-08-19 00:03:47 EDT
In version 8.0.0 I've changed this to read "(every thirty days)" because "one
month" is not specific (28 - 31 days). I've not made any changes to previous
versions.
Comment 4 Deon Ballard 2008-05-06 11:03:13 EDT
Reassigning daobrien's bugs (and one mhideo bug) to dlackey.
Setting the target milestone to 8.0
Comment 5 Deon Ballard 2008-05-06 12:32:51 EDT
Setting to block 8.0 tracking bug.
Comment 6 Deon Ballard 2008-05-13 20:02:36 EDT
This has been corrected on redhat.com already for the 7.3 docs, in the course of
other updates. Cf.
http://www.redhat.com/docs/manuals/cert-system/7.3/html/Administration_Guide/Administration_Guide-Buffered_Versus_Unbuffered_Logging-Log_File_Rotation.html

I have carried this over to the 7.2 docs, and they'll be pushed soon.

I don't think there's much that can be done about the 7.1 docs; the source files
are lost. With 7.2, 7.3, and future docs correct, do you think it's all right to
leave the 7.1 docs as-is?

Note You need to log in before you can comment on or make changes to this bug.