Bug 247222 - Missing MIME type for .ico files
Missing MIME type for .ico files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mailcap (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 23:29 EDT by Todd Taft
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 10:47:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Taft 2007-07-05 23:29:38 EDT
Description of problem:
The MIME type for files of type image/vnd.microsoft.icon (standard extension
.ico) is not defined in the standard file /etc/mime.types . This file format is
a standard format accepted by IANA, as described at
http://www.iana.org/assignments/media-types/image/vnd.microsoft.icon
Since this is an IANA defined file type, please add this definition to the
standard mime.types file. 

Version-Release number of selected component (if applicable):
mailcap-2.1.23-1.fc6

How reproducible:
Always

Steps to Reproduce:
1.  Put an icon file in the DocumentRoot directory of your apache web server
(e.g. favicon.ico)
2.  With firefox, go to http://localhost/favicon.ico
  
Actual results:
Garbled text appears in the web browser

Expected results:
An icon appears in the web browser

Additional info:
Note: This also needs to be done for other supported platforms/releases,
including RHEL 5.  However, I will not open a separate report for each (unless
you request it).
Comment 1 Miroslav Lichvar 2007-07-10 10:47:38 EDT
Fixed in mailcap-2.1.25-1.fc8. Thanks.

As for RHEL5, please contact Red Hat Support to get it escalated.

Note You need to log in before you can comment on or make changes to this bug.