Bug 247241 - initng and selinux + powersave
initng and selinux + powersave
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: initng (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Malmgren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-06 05:05 EDT by Stian Moltubakk
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-28 06:53:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the hang and/or segfault when selinux is disabled (489 bytes, patch)
2007-10-27 08:42 EDT, drago01
no flags Details | Diff

  None (edit)
Description Stian Moltubakk 2007-07-06 05:05:52 EDT
Description of problem:
When selinux is disabled initng won't boot my computer.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install initng.
2.Disable SeLinux
3.Reboot into the initng kernel
  
Actual results:
Boot stops and display error mesages


Expected results:
Boot with no problem


Additional info:
I tested my boot speed with Selinux and figured out it was about 1:20minutes.
I tested my boot speed with initng and found it to be about 1minute.
I then disabled Se linux and tested my boot speed to about 1:10 minutes.
A final atemt was to test initng and no Selinux, but it failed to boot.
After enabling SElinux the initng boot's again.

Another funny thing is that kpowersave crash on my system unless I'm root, but 
booting with initng don't make kpowersave crash, but no information is present.
Comment 1 Andrea V. 2007-07-12 01:39:19 EDT
I had the same error on my x86_32 system, so I switched on selinux and the 
system booted correctly.
Comment 2 George Billios 2007-08-19 09:17:01 EDT
Confirming this bug when selinux is disabled. 

Enabling selinux in *not* a solution, tried to change initng files a bit to
'remove' selinux references but didn't succeed. 

Any help would be appreciated. 
Comment 3 Daniel Malmgren 2007-08-20 09:52:18 EDT
Hmmm... The strange thing here is that I've never used selinux myself and initng
works fine here, both on 32 and 64 bit machines. I need some more info here. For
example, what services/daemons are started at startup? (What's the content of
/etc/initng/runlevels/default.runlevel and
/etc/initng/runlevels/system.virtual?) What are the error messages?
Comment 4 George Billios 2007-08-20 10:33:48 EDT
Here you go

default.runlevel:

daemon/acpid
daemon/dbus
daemon/dcron
daemon/gdm
daemon/hald
daemon/klogd
daemon/portmap
daemon/syslogd
net/eth0
runlevel/system
service/alsasound
service/alsasound/cards
service/alsasound/mixerstate
service/speedstep

system.virtual:

net/lo
service/iptables
system/agetty
system/clock
system/hdparm
system/hostname
system/keymaps
system/modules
system/mountfs
system/swap
system/udev
system/urandom
system/usb


These should be the default entries since I haven't changed any of these, as far
as the error messages its a bit tricky cause there are a lot to copy in paper,
but I remember the error start in loglevel service or whatever that is and are
about selinux. 
Comment 5 Daniel Malmgren 2007-08-23 03:02:12 EDT
I really have no idea on this one. I know initng has been having troubles with
selinux, but I've never heard of it having trouble with selinux not being
activated. Another strange thing is that you don't have the selinux services in
the default runlevel, they should have been there.

I'll CC dragoran. You got any ideas?
Comment 6 drago01 2007-08-24 18:10:30 EDT
what does happen you boot with selinux disabled? does it just hangs or do you
get any error messages? where exactly does it hang (at which script) or does it
not even try to start scripts?
Comment 7 drago01 2007-10-27 08:42:33 EDT
Created attachment 240351 [details]
patch to fix the hang and/or segfault when selinux is disabled

The attached patch should fix the issue. If not try to this patch + disabling
the selinux/relabel service.
Comment 8 George Billios 2007-10-28 05:13:58 EDT
Indeed this patch solves the problem - some other problems appear later on but
not related to selinux. 

Comment 9 Daniel Malmgren 2007-10-28 06:53:18 EDT
I'll close this bug, since Dragoran attached his working patch to upstreams svn.
I'll try manipulating people into doing another release (0.6.10.2?), since we
now has got some fixes in svn...

Note You need to log in before you can comment on or make changes to this bug.