Bug 247249 - xen doesn't show changeset information
xen doesn't show changeset information
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Gerd Hoffmann
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-06 07:27 EDT by Gerd Hoffmann
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 09:48:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xen src tree patch (928 bytes, patch)
2007-07-06 07:28 EDT, Gerd Hoffmann
no flags Details | Diff
kernel spec file patch (1.45 KB, patch)
2007-07-06 07:29 EDT, Gerd Hoffmann
no flags Details | Diff

  None (edit)
Description Gerd Hoffmann 2007-07-06 07:27:41 EDT
Description of problem:
xen doesn't show changeset information, neither in the boot log
nor in the "xm info" output.

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-el32 (xen coming with 3.1)

How reproducible:
"xm info"

Actual results:
[root@rhel5 ~]# xm info
[ ... ]
xen_changeset          : unavailable
[ ... ]

Expected results:
[root@rhel5 ~]# xm info
[ ... ]
xen_changeset          : 15042
[ ... ]

Additional info:
Comment 1 Gerd Hoffmann 2007-07-06 07:28:43 EDT
Created attachment 158651 [details]
xen src tree patch
Comment 2 Gerd Hoffmann 2007-07-06 07:29:14 EDT
Created attachment 158652 [details]
kernel spec file patch
Comment 3 Gerd Hoffmann 2007-07-06 07:30:44 EDT
posted for review on 2007-07-22
Comment 4 Stephen Tweedie 2007-07-06 07:40:48 EDT
I think we need this to include a clear indication that the release is NOT a
specific upstream changeset, but is in fact our own variant on that, complete
with other patches.  So perhaps

xen_changeset          : 15042.el5

makes sense.

Requesting for 5.2.
Comment 5 Stephen Tweedie 2007-07-06 07:43:13 EDT
Also, what do we do about the fact that userland is based off multiple different
releases (one for python, another for hvm environment); and that the kernel and
hypervisor are based off different csets, too?

Sounds like "unavailable" is actually the most accurate response to a user
asking what our Xen version is.  :)
Comment 6 Daniel Berrange 2007-07-06 09:30:38 EDT
Personally I recommend against including any form of changeset information,
simply because there is no meaningful changeset we can provide. The HV may be
based off 3.1, but its got a number of patches added. The userspace bears no
resemblance to any upstream changeset. Nor does the kernel. We should not try to
pretend that we have any correspondance to a changeset because it'll just
encourage people to make meaningless comparisons between functionality/bugs in
upstream vs our tree.
Comment 7 Red Hat Bugzilla 2007-07-24 20:53:41 EDT
change QA contact

Note You need to log in before you can comment on or make changes to this bug.