Bug 247250 - Conflicting Provides
Conflicting Provides
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mod_perl (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-07-06 07:27 EDT by Michael Schwendt
Modified: 2012-05-03 12:22 EDT (History)
4 users (show)

See Also:
Fixed In Version: mod_perl-2.0.5-8.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 818651 (view as bug list)
Environment:
Last Closed: 2012-03-21 15:04:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed patch (1.89 KB, patch)
2012-03-05 08:05 EST, Jan Kaluža
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2007-07-06 07:27:59 EDT
mod_perl-devel provides perl(HTTP::Request::Common)
perl-libwww-perl provides perl(HTTP::Request::Common) EQ 0 1.26
  required by: perl-bioperl - 1.5.2_102-8.fc7.noarch
  required by: perl-Finance-Quote - 1.13-1.fc7.noarch
  required by: perl-Finance-YahooQuote - 0.21-2.fc7.noarch
  required by: perl-WWW-Babelfish - 0.16-1.fc7.noarch
  required by: perl-bioperl-run - 1.5.2_100-2.fc7.noarch
  required by: rt3 - 3.6.3-1.fc7.noarch
  required by: perl-bioperl - 1.5.2_102-8.fc7.noarch
  required by: perl-Finance-Quote - 1.13-1.fc7.noarch
  required by: perl-Finance-YahooQuote - 0.21-2.fc7.noarch
  required by: perl-WWW-Babelfish - 0.16-1.fc7.noarch
  required by: perl-bioperl-run - 1.5.2_100-2.fc7.noarch
  required by: rt3 - 3.6.3-1.fc7.noarch

Indeed:

$ sudo yum install 'perl(HTTP::Request::Common)'

does not install perl-libwww-perl, but mod_perl-devel and
more than a dozen dependencies.

The culprit is the Apache::TestRequest module.

[...]

Further reference, similar cases:
https://www.redhat.com/archives/fedora-perl-devel-list/2007-July/msg00011.html
Comment 1 Michael Schwendt 2007-09-05 06:48:36 EDT
mod_perl-devel provides perl(HTTP::Request::Common)
perl-libwww-perl provides perl(HTTP::Request::Common) EQ 0 1.28
  required by: perl-Finance-Quote - 1.13-1.fc7.noarch
  required by: perl-Finance-YahooQuote - 0.21-2.fc7.noarch
  required by: perl-WWW-Babelfish - 0.16-1.fc7.noarch
  required by: perl-bioperl - 1.5.2_102-8.fc8.noarch
  required by: perl-bioperl-run - 1.5.2_100-2.fc8.noarch
  required by: rt3 - 3.6.3-1.fc7.noarch
  required by: perl-Finance-Quote - 1.13-1.fc7.noarch
  required by: perl-Finance-YahooQuote - 0.21-2.fc7.noarch
  required by: perl-WWW-Babelfish - 0.16-1.fc7.noarch
  required by: perl-bioperl - 1.5.2_102-8.fc8.noarch
  required by: perl-bioperl-run - 1.5.2_100-2.fc8.noarch
  required by: rt3 - 3.6.3-1.fc7.noarch
Comment 2 Joe Orton 2007-09-05 08:09:18 EDT
Sorry for the delay.

http://koji.fedoraproject.org/koji/buildinfo?buildID=17832
Comment 3 Petr Pisar 2012-02-02 09:00:42 EST
The bogus perl(HTTP::Request::Common) is back again:

# repoquery --whatprovides 'perl(HTTP::Request::Common)' --source
perl-HTTP-Message-6.02-4.fc17.src.rpm
mod_perl-2.0.5-7.fc17.src.rpm
mod_perl-2.0.5-7.fc17.src.rpm
Comment 4 Jan Kaluža 2012-03-05 08:05:00 EST
Created attachment 567603 [details]
proposed patch

filter perl(HTTP::Request::Common) Provide from -devel
Comment 5 Fedora Update System 2012-03-06 03:37:23 EST
mod_perl-2.0.5-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mod_perl-2.0.5-8.fc17
Comment 6 Fedora Update System 2012-03-06 03:56:52 EST
mod_perl-2.0.5-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mod_perl-2.0.5-8.fc16
Comment 7 Fedora Update System 2012-03-07 02:22:10 EST
Package mod_perl-2.0.5-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mod_perl-2.0.5-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3185/mod_perl-2.0.5-8.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-03-21 15:04:34 EDT
mod_perl-2.0.5-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Harald Reindl 2012-04-05 15:33:29 EDT
and that you see what impact such small bugs are having
here the list what canbe removed on a single server now

in our case there are 20 virtual machines with the
package - in summary 1600 MB caused by one simple
packaging bug

===============================================================================================================
 Package                           Arch        Version                          Repository               Größe
===============================================================================================================
Entfernen:
 apr-devel                         x86_64      1.4.6-1.fc16.20120325.rh         @lounge-buildserver      767 k
 apr-util-devel                    x86_64      1.3.12-1.fc16                    @lounge-cache            260 k
 cyrus-sasl-devel                  x86_64      2.1.23-27.fc16                   @lounge-cache            982 k
 db4-cxx                           x86_64      4.8.30-3.fc15                    @lounge-cache/15         1.6 M
 db4-devel                         x86_64      4.8.30-3.fc15                    @lounge-cache/15          68 M
 expat-devel                       x86_64      2.1.0-1.fc16                     @lounge-cache            178 k
 httpd-devel                       x86_64      2.2.22-5.fc16.20120325.rh        @lounge-buildserver      523 k
 mod_perl-devel                    x86_64      2.0.5-8.fc16                     @lounge-cache            896 k
 openldap-devel                    x86_64      2.4.26-6.fc16                    @lounge-cache            5.1 M
 perl-Archive-Tar                  noarch      1.76-197.fc16                    @lounge-cache            121 k
 perl-CPAN-Meta                    noarch      2.120630-1.fc16                  @lounge-cache            386 k
 perl-CPAN-Meta-YAML               noarch      0.004-1.fc16                     @lounge-cache             40 k
 perl-ExtUtils-CBuilder            noarch      1:0.28.2.3-197.fc16              @lounge-cache             61 k
 perl-ExtUtils-Embed               noarch      1.30-197.fc16                    @lounge-cache             17 k
 perl-IO-Zlib                      noarch      1:1.10-197.fc16                  @lounge-cache             19 k
 perl-IPC-Cmd                      noarch      1:0.70-197.fc16                  @lounge-cache             64 k
 perl-JSON-PP                      noarch      2.27200-2.fc16                   @lounge-cache            117 k
 perl-Locale-Maketext-Simple       noarch      1:0.21-197.fc16                  @lounge-cache             14 k
 perl-Module-Build                 noarch      1:0.3800-197.fc16                @lounge-cache            495 k
 perl-Module-Load                  noarch      1:0.18-197.fc16                  @lounge-cache            7.3 k
 perl-Module-Load-Conditional      noarch      0.44-197.fc16                    @lounge-cache             24 k
 perl-Module-Metadata              noarch      1.000006-1.fc16                  @lounge-cache             27 k
 perl-Package-Constants            noarch      1:0.02-197.fc16                  @lounge-cache            4.6 k
 perl-Params-Check                 noarch      1:0.28-197.fc16                  @lounge-cache             25 k
 perl-Parse-CPAN-Meta              noarch      1:1.4401-197.fc16                @lounge-cache             11 k
 perl-Perl-OSType                  noarch      1.002-197.fc16                   @lounge-cache            6.1 k
 perl-Test-Simple                  noarch      0.98-197.fc16                    @lounge-cache            195 k

Vorgangsübersicht
===============================================================================================================
Remove  27 Packages

Installationsgröße: 80 M
Ist dies in Ordnung? [j/N] :j
Comment 10 Fedora Update System 2012-05-03 03:22:41 EDT
mod_perl-2.0.5-8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.