Bug 247258 - Unhandled exception. Installer detects sda instead of hda
Unhandled exception. Installer detects sda instead of hda
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-06 08:35 EDT by Jens Radloff
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 15:48:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error log (70.97 KB, text/plain)
2007-07-06 08:35 EDT, Jens Radloff
no flags Details

  None (edit)
Description Jens Radloff 2007-07-06 08:35:39 EDT
Description of problem:

i tried to install fc 7 (Version 7.0.0 (2007-04-20)) using the minimal boot 
cd, using sources via http. first strange thing: after images/stage2.img is 
loaded and gui is started:

"the drive /dev/sda has more than 15 partitions on it. the scsi subsystem in 
the linux kernel does not allow for more than 15 partitions at this time. you 
will not be able to make changes to the partitioning of this disk or use any 
partitions beyond /dev/sda15"

But i do not have a scsi hard disk. i have one ide disk, a SAMSUNG SP0802N. 

fdisk prints this (running in my second linux installation, a linux from 
scratch installation):

    Gerät boot.     Anfang        Ende     Blöcke   Id  System
/dev/hda1   *           1         392     3148708+   7  HPFS/NTFS
/dev/hda2             393        1172     6265350   83  Linux
/dev/hda3            1173        1952     6265350   83  Linux
/dev/hda4            1953        9733    62500882+   f  W95 Erw. (LBA)
/dev/hda5            1953        2083     1052226    7  HPFS/NTFS
/dev/hda6            2084        2344     2096451    b  W95 FAT32
/dev/hda7            2345        2408      514048+  83  Linux
/dev/hda8            2409        3061     5245191   83  Linux
/dev/hda9            3062        3078      136521   82  Linux swap / Solaris
/dev/hda10           3079        3209     1052226   83  Linux
/dev/hda11           3210        3862     5245191   83  Linux
/dev/hda12           3863        4646     6297448+  83  Linux
/dev/hda13           4647        4659      104391   83  Linux
/dev/hda14           4660        4791     1060258+  83  Linux
/dev/hda15           4922        5313     3148708+  83  Linux
/dev/hda16           5314        6620    10498446   83  Linux
/dev/hda17           9120        9733     4931923+  83  Linux

I ignored the sda partitioning warning and told the installer to format 
certain partitions, which was done. Then, having specified which packages to 
install (i used the default ones), an "unhandled exception" occured with the 
following error report:

Traceback (most recent call first):
  File "/usr/lib/anaconda/partedUtils.py", line 1163, in openDevices
    rc = intf.messageWindow(_("Warning"),
  File "/usr/lib/anaconda/fsset.py", line 118, in createLabel
    diskset.openDevices()
  File "/usr/lib/anaconda/fsset.py", line 581, in labelDevice
    kslabel = entry.label)
  File "/usr/lib/anaconda/fsset.py", line 1538, in labelEntry
    entry.fsystem.labelDevice(entry, chroot)
  File "/usr/lib/anaconda/fsset.py", line 1636, in makeFilesystems
    self.labelEntry(entry, chroot)
  File "/usr/lib/anaconda/packages.py", line 153, in turnOnFilesystems
    anaconda.id.fsset.makeFilesystems (anaconda.rootPath)
  File "/usr/lib/anaconda/dispatch.py", line 203, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1041, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 67, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1068, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoneType' object has no attribute 'messageWindow'
[...]

(Complete error log in attachment)

i tried two different http repositories: same result

Version-Release number of selected component (if applicable):


How reproducible:

i tried two different http repositories: same result

Steps to Reproduce:

see above

  
Actual results:


Expected results:


Additional info:
Comment 1 Jens Radloff 2007-07-06 08:35:39 EDT
Created attachment 158656 [details]
Error log
Comment 2 Jens Radloff 2007-07-06 13:22:28 EDT
b.t.w: same result with the fedora 7 live cd
Comment 3 Jeremy Katz 2007-07-06 15:51:57 EDT
With the change to using libata for IDE devices in 2.6.21, all disks are
accessed through the SCSI layer 
Comment 4 Jens Radloff 2007-07-30 16:03:59 EDT
Jeremy Katz wrote:
> With the change to using libata for IDE devices in 2.6.21, all disks are
> accessed through the SCSI layer 

Thanks for the informatin, OK, but strange. Now no more than 15 partitions? Is 
this really handy?

Anyway, I reported the "unhandled exception" during installation, see the 
initial comment in this bug report. I cannot install Fedora ...
Comment 5 David Cantrell 2007-08-16 15:48:16 EDT
We've corrected the unhandled exception, but the 15 partition limit is part of
the current SCSI subsystem in Linux.  It's a limitation of the kernel, not
arbitrarily enforced by anaconda.

Note You need to log in before you can comment on or make changes to this bug.