Bug 247266 - Dell D420 with intel driver doesn't resume after suspend
Dell D420 with intel driver doesn't resume after suspend
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-07-06 10:31 EDT by Julien Tognazzi
Modified: 2008-06-16 21:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 21:49:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg log file (86.64 KB, text/plain)
2007-07-06 10:31 EDT, Julien Tognazzi
no flags Details
Xorg.0.log (53.44 KB, application/octet-stream)
2007-11-27 10:34 EST, Julien Tognazzi
no flags Details
My Xorg conf (1.78 KB, application/octet-stream)
2007-11-27 10:35 EST, Julien Tognazzi
no flags Details
Failed autodetection without any xorg.conf (55.34 KB, application/octet-stream)
2007-11-27 10:37 EST, Julien Tognazzi
no flags Details

  None (edit)
Description Julien Tognazzi 2007-07-06 10:31:30 EDT
Description of problem:
My D420 laptop doesn't resume when X is running. From init 3, the suspend/resume
work OK.
After resume, the mouse cursor appear but then X seems to restart and then
eventually freeze.
The laptop is still reachable vie the network.

Version-Release number of selected component (if applicable):
X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3 
Build Operating System: Fedora Core 7 Red Hat, Inc.
Current Operating System: Linux erdinger 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12
15:37:31 EDT 2007 i686
Build Date: 11 June 2007
Build ID: xorg-x11-server 


00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML
Express Integrated Graphics Controller (rev 03)

How reproducible:
always when suspending from init 5

Steps to Reproduce:
1. Choose to suspend the laptop
2. then resume by pressing the power button
Actual results:
The laptop seems to resume fine (hdd led blinking), X starting, mouse cursor
appearing, but then, X seems to restart and then freezes

Expected results:
Returning to previous X sessions

Additional info:
The probleme seems very close to the one describe there:
It might be a kernel bug...
Comment 1 Julien Tognazzi 2007-07-06 10:31:30 EDT
Created attachment 158663 [details]
Xorg log file
Comment 2 Julien Tognazzi 2007-07-06 12:01:13 EDT
oups, my laptop model is D620 and not D420, sorry.
Comment 3 Chris Maynard 2007-08-09 21:31:09 EDT
Same here, with a D610. On updates-testing. Started fairly recently, but I'm not
sure exactly when. xorg-x11-drv-i810-2.1.0-1.fc7

When using the script from the thread above, the display comes up in what
appears to be the wrong mode. Switching to a VT, blindly running vbetool post,
and then switching back to X fixes the problem.

Here are the commands from the thread:
chvt 12
cat /proc/bus/pci/00/02.0 > /var/run/video.state.o
cat /proc/bus/pci/00/02.1 > /var/run/video.state.1
echo mem > /sys/power/state 
cat /var/run/video.state.1 > /proc/bus/pci/00/02.1
cat /var/run/video.state.o > /proc/bus/pci/00/02.0
chvt 7
Comment 4 Matěj Cepl 2007-11-26 17:35:51 EST
To make things slightly more standard (I am really sorry for letting this bug
rotten for so long), please attach your X server config file
(/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug
report as individual uncompressed file attachments using the bugzilla file
attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Julien Tognazzi 2007-11-27 10:34:37 EST
Created attachment 269841 [details]

So I've updated my system with the latest RPMs and tried to suspend and resume.

Here are the log file.
From startx till the resume failed.
Comment 6 Julien Tognazzi 2007-11-27 10:35:37 EST
Created attachment 269851 [details]
My Xorg conf

Here is my xorg.conf file
Comment 7 Julien Tognazzi 2007-11-27 10:37:17 EST
Created attachment 269861 [details]
Failed autodetection without any xorg.conf

I also tried to let X11 autodetect the card, but it failed...
Comment 8 Jesse Barnes 2008-01-10 18:14:09 EST
Yep, definitely looks like it's falling over on resume. :)

Can you try the most recent bits?  IIRC rawhide even has some kernel bits to 
suspend/resume the card a bit more fully, so that may fix things for you.
Comment 9 Bug Zapper 2008-05-14 09:26:20 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2008-06-16 21:48:58 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.