Bug 247303 - BUG: biosdisk installs broken in some scenarios when unique disk signature dont exist
Summary: BUG: biosdisk installs broken in some scenarios when unique disk signature do...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 4.5
Hardware: All
OS: Linux
low
high
Target Milestone: ---
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords: OtherQA
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-06 19:06 UTC by Sandeep K. Shandilya
Modified: 2009-06-19 23:31 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0816
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 16:36:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backport from rhel5 to fix this issue. (5.26 KB, patch)
2007-07-06 19:06 UTC, Sandeep K. Shandilya
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0816 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2007-11-14 18:43:57 UTC

Description Sandeep K. Shandilya 2007-07-06 19:06:50 UTC
Description of problem:
biosdisks install broken when we have 3 disks (bios disk 80,81,82) we want to
install to disk 80 from the hard disk we have ks=bd:80p1:/ks.cfg in command line
and in the ks.cfg we have the line
harddrive --biospart=80p1 --dir=/
and only disk80 has a valid signature. the other 2 disks have zero signatures
Version-Release number of selected component (if applicable):
anaconda-10.1.1.63

How reproducible:
always


Steps to Reproduce:
1. on a system with 3 disks, write a signature on the first disk (that will be
disk80) then dd the mbr of the other disks with zero.
2. begin a ks install from hard disk with the lines in ks.cfg targetting disk80
3.
  
Actual results:
we get a message cannot find biosdisk 80 and the install aborts.

Expected results:
The install should continue because we a match signature match for the disk80

Additional info:
I have attached a probable patch to fix this issue. It is a back port from rhel 5.

Comment 1 Sandeep K. Shandilya 2007-07-06 19:06:50 UTC
Created attachment 158694 [details]
backport from rhel5 to fix this issue.

Comment 2 RHEL Product and Program Management 2007-08-09 15:56:01 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Charles Rose 2007-08-20 11:00:17 UTC
Dell can test this fix when the RHEL4.6 code is available.

Comment 5 David Cantrell 2007-08-21 21:50:19 UTC
Adding devel-ack based on patch in comment #1.

Comment 6 Larry Troan 2007-08-30 13:40:13 UTC
Per Dell call on 8/30, they will test. Setting OtherQA.

Comment 11 Sandeep K. Shandilya 2007-09-13 11:41:44 UTC
reply to comment #6
Larry, which version of anaconda will have this patch?
anaconda version 10.1.1.69 does not have this patch.

Comment 12 srinivas 2007-09-26 15:33:35 UTC
This issue is not fixed. The patch hasn't seemed to have made it for RHEL 4.6
anaconda ( 10.1.1.69).

Comment 13 David Cantrell 2007-10-02 13:56:24 UTC
The patch for this fix is in anaconda-10.1.1.70 and later, which should make it
in to the next snapshot.

Comment 16 Brock Organ 2007-10-25 15:43:36 UTC
Hi, has this issue been solved with the latest 4.6 snapshot?

Regards,

Brock


Comment 17 Sandeep K. Shandilya 2007-10-26 11:02:00 UTC
Yes this issue has been solved with the latest 4.6 snapshot.

Comment 18 Brock Organ 2007-10-26 15:00:06 UTC
ok, thanks for the feedback ... :)

Comment 21 errata-xmlrpc 2007-11-15 16:36:24 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0816.html



Note You need to log in before you can comment on or make changes to this bug.