Bug 24733 - gps component causes startup/shutdown errors
Summary: gps component causes startup/shutdown errors
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: gps   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Powers
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-23 19:48 UTC by josip
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-23 21:39:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description josip 2001-01-23 19:48:59 UTC
Package gps-0.8.1-10 causes errors on startup and on shutdown because:

(1) /etc/init.d/rgpsp has a typo (tries to return '?$' instead of '$?')
(2) on startup, gps launches subsystem rgpsp_linux instead of just rgpsp

Suggested fix:
(1) edit /etc/init.d/rgpsp to return '$?'
(2) ln -s rgpsp_linux /etc/init.d/rgpsp

Comment 1 David Mason 2001-01-23 19:56:09 UTC
The Red Hat gnome-utils package does not come with gps - you must have either
downloaded it and installed, or gotten your gnome-utils from another source
(Helix?). You may send a bug report to the maintainer of Gps at:
http://gps.seul.org/


Comment 2 josip 2001-01-23 20:52:18 UTC
While this did not come with RedHat 7.0, it is distributed with Red Hat 7.0
powertools:

gps-0.8.1-10.i386.rpm

Name        : gps                          Relocations: (not relocateable)
Version     : 0.8.1                             Vendor: Red Hat, Inc.
Release     : 10                            Build Date: Fri Jul 28 18:06:54 2000
Install date: Sun Jan 21 22:13:48 2001      Build Host: porky.devel.redhat.com
Group       : Applications/System           Source RPM: gps-0.8.1-10.src.rpm
Size        : 323235                           License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.dcc.unicamp.br/~guazzibe/gPS/
Summary     : A graphical system process monitor.


Comment 3 josip 2001-01-23 21:05:38 UTC
Suggested fix (2) above should read

ln -s rgpsp /etc/init.d/rgpsp_linux


Comment 4 David Mason 2001-01-23 21:39:01 UTC
Ah - powertools. My apologies, you are correct. Assigning.

Comment 5 Tim Powers 2001-01-23 21:58:56 UTC
FWIW, problem #1 was fixed(it's in rawhide). For problem #2 I am going to rename
rgpsp to rgpsp_linux to avoid having symlinks in /etc/init.d.

You should see the updated package in rawhide the next time rawhide is updated
with both of these fixes.

Tim


Note You need to log in before you can comment on or make changes to this bug.