Bug 247346 - tickless kernel boots only when using 'nohpet' on x86_64
tickless kernel boots only when using 'nohpet' on x86_64
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-07-07 08:33 EDT by Thorsten Leemhuis
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-29 23:58:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci on X60 1706-GMG under 2.6.22-8.fc8 (2.10 KB, text/plain)
2007-07-11 12:07 EDT, Patrick C. F. Ernzer
no flags Details
knurd lspci dell d630 (2.70 KB, application/octet-stream)
2007-07-11 12:16 EDT, Thorsten Leemhuis
no flags Details
lspci output from IBM/Lenovo T60 (1.93 KB, text/plain)
2007-07-11 12:22 EDT, Tom "spot" Callaway
no flags Details
lspci output fot Toshiba Satellite A100-847 (2.01 KB, text/plain)
2007-07-11 17:02 EDT, Julian Sikorski
no flags Details
Fix the hpet boot problem (640 bytes, patch)
2007-07-12 03:20 EDT, Thomas Gleixner
no flags Details | Diff

  None (edit)
Description Thorsten Leemhuis 2007-07-07 08:33:43 EDT
Description of problem:
I'm running kernels from rawhide on F-7 on my new (one week old) notebook (Dell
D630; GM965-Chipset). Kernel 2.6.21-1.3240.fc8 ran fine, but beginning with
2.6.22-0.9.rc7.git3.fc8 the kernels did not boot. You select them in grub and
grub switches back to the black screen and that's all -- no further output  at
all. Kernel starts fine when I pass "nohpet" as kernel parameter. 

Version-Release number of selected component (if applicable):
2.6.22-0.9.rc7.git3.fc8
2.6.22-0.21.rc7.git5.fc8 (the patch that was added in between one did not change
the behavior)

How reproducible:
always

Additional info:
Was discussed on the mailing list a bit already
https://www.redhat.com/archives/fedora-devel-list/2007-July/msg00416.html

My dmesg:
http://leemhuis.info/files/fedorarpms/MISC.fdr/dmesg-d630

Feel free to grab me as knurd in #fedora-devel if you need real-time informations
Comment 1 drago01 2007-07-07 08:42:29 EDT
same here with my ICH7 based Zepto 6615WD, also the hpet is enabled in the bios
and works fine with non tickless kernel. So the "force hpet" patches seems not
to be the cause for this.
Comment 2 Patrick C. F. Ernzer 2007-07-09 07:22:42 EDT
Same problem and work-around as in the original bug description on a Lenovo X60
type 1706-GMG (Core2Duo,  T7200, 2.00GHz and ICH7 chipset)

Only difference to original report is that if I do not use a vga=... parameter,
I at least get a 'Kernel is alive'
Comment 3 Thorsten Leemhuis 2007-07-09 07:34:11 EDT
Setting arch to x86_64, as that's what I and drago (comment #2) use. I can try
the F7-i386-live CD if that is any help

(In reply to comment #2)
> Only difference to original report is that if I do not use a vga=... parameter,
> I at least get a 'Kernel is alive'

Not sure, maybe it's there for me as well.


Comment 4 Karsten Hopp 2007-07-09 08:07:34 EDT
Same as comment #3 here with a standard dual Opteron 244 workstation and a 
Tyan Thunder K8W mainboard. Machine boots fine with 'nohpet'
Comment 5 Tom "spot" Callaway 2007-07-09 15:01:25 EDT
Same here. IBM/Lenovo T60 x86_64. 

kernel-2.6.21-1.3243.fc8 boots fine, kernel-2.6.22-0.21.rc7.git5.fc8 doesn't
boot without nohpet. If i disable vga=, I see "Kernel is alive".
Comment 6 Chuck Ebbert 2007-07-09 15:53:28 EDT
Could reporters please try intermediate version of the fc8 kernel?
I can't pin this bug down to any particular change.

From koji (http://koji.fedoraproject.org/koji/packageinfo?packageID=8)

1.3242:       http://koji.fedoraproject.org/koji/buildinfo?buildID=10009
1.3243:       http://koji.fedoraproject.org/koji/buildinfo?buildID=10102
1.3244:       http://koji.fedoraproject.org/koji/buildinfo?buildID=10174
0.5.rc7.git2: http://koji.fedoraproject.org/koji/buildinfo?buildID=10329
Comment 7 Jarod Wilson 2007-07-09 15:57:24 EDT
Same problem on a Dell Precision 470 (dual 2.8GHz xeons).
Comment 8 drago01 2007-07-09 16:09:47 EDT
(In reply to comment #6)
> Could reporters please try intermediate version of the fc8 kernel?
> I can't pin this bug down to any particular change.
> 
> From koji (http://koji.fedoraproject.org/koji/packageinfo?packageID=8)
> 
> 1.3242:       http://koji.fedoraproject.org/koji/buildinfo?buildID=10009
> 1.3243:       http://koji.fedoraproject.org/koji/buildinfo?buildID=10102
> 1.3244:       http://koji.fedoraproject.org/koji/buildinfo?buildID=10174
> 0.5.rc7.git2: http://koji.fedoraproject.org/koji/buildinfo?buildID=10329
> 

I am sure that the tickless x86_64 caused this... thats why it only happens on
x86_64.
Comment 9 Tom "spot" Callaway 2007-07-09 16:11:10 EDT
All of those kernels boot fine on my Lenovo T60 (the last one needed to be
--nodeps'd in because of mkinitrd) without passing nohpet.

It looks like the failure is somewhere after 0.5.rc7.git2. Earliest reported
failure is in 0.9.rc7.git3.
Comment 10 Jarod Wilson 2007-07-09 16:21:03 EDT
Likewise, 0.5.rc7.git2 works for me w/o nohpet added to the boot options, didn't
bother trying earlier ones.
Comment 11 Chuck Ebbert 2007-07-09 17:05:33 EDT
(In reply to comment #9)
> It looks like the failure is somewhere after 0.5.rc7.git2. Earliest reported
> failure is in 0.9.rc7.git3.

That's when tickless x86_64 went in:

$ cvs annotate kernel-2.6.spec | sort -n -k 1.3,1.6 -s
1.3267       (davej    04-Jul-07): ApplyPatch linux-2.6-highres-timers.patch

1.3267       (davej    04-Jul-07): - x86-64 tickless support.
1.3267       (davej    04-Jul-07):
1.3268       (davej    04-Jul-07): - 2.6.22-rc7-git3
Comment 12 Dave Jones 2007-07-10 22:05:21 EDT
is this still busted on the final 2.6.22 kernel ?
Comment 13 Dave Jones 2007-07-10 22:05:54 EDT
(oh, and if so, lspci output please)
Comment 14 drago01 2007-07-11 09:47:03 EDT
yes still the same with kernel-2.6.22-2.fc7 .
lspci output:
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI
Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce Go 7600] (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 01)
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)
04:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
04:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394
Host Controller
04:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader
(SD/MMC/MS/MS PRO/xD)
04:06.3 Generic system peripheral [0805]: Texas Instruments PCIxx12 SDA Standard
Compliant SD Host Controller
Comment 15 Patrick C. F. Ernzer 2007-07-11 12:07:50 EDT
Created attachment 158964 [details]
lspci on X60 1706-GMG under 2.6.22-8.fc8

In response to Comments #12 and #13:
yes, still same problem under 2.6.22-8.fc8
Comment 16 Thorsten Leemhuis 2007-07-11 12:16:51 EDT
Created attachment 158966 [details]
knurd lspci dell d630

(In reply to comment #12)
> is this still busted on the final 2.6.22 kernel ?

Yes, still happens with 2.6.22-2.fc7 as outlined in initial comment
Comment 17 Tom "spot" Callaway 2007-07-11 12:22:13 EDT
Created attachment 158968 [details]
lspci output from IBM/Lenovo T60

2.6.22-8.fc8 won't boot without nohpet on my T60. Here's the lspci output.
Comment 18 Chuck Ebbert 2007-07-11 12:26:12 EDT
Happens on 2.6.22-4.fc6 too, on Dell Workstation 490. Boots only with "nohpet".
Time to drop the highres-timers patch in FC6?
Comment 19 Thomas Gleixner 2007-07-11 12:53:49 EDT
I have "indirect" access to a T60. Debugging right now.
Comment 20 Julian Sikorski 2007-07-11 17:02:02 EDT
Created attachment 159003 [details]
lspci output fot Toshiba Satellite A100-847

Problem still persists in kernel-2.6.22-5.fc7.
Comment 21 Thomas Gleixner 2007-07-12 03:20:12 EDT
Created attachment 159035 [details]
Fix the hpet boot problem

Thorsten provided the debug info to decode the problem and confirmed, that the
fix works.

Thanks Thorsten !

    tglx
Comment 22 Jarod Wilson 2007-07-12 12:16:46 EDT
Fix works on my ICH5 Dell Precision 470 as well.
Comment 23 Patrick C. F. Ernzer 2007-07-16 07:47:56 EDT
Problem still exists with 2.6.23-0.15.rc0.git1.fc8
Hardware as decribed in Comment #15
Comment 24 drago01 2007-07-16 07:52:03 EDT
(In reply to comment #23)
> Problem still exists with 2.6.23-0.15.rc0.git1.fc8
> Hardware as decribed in Comment #15

the patch is not applied to the builds yet...
Comment 25 Will Woods 2007-07-24 15:39:32 EDT
2.6.23-0.45.rc0.git16.fc8 has tickless disabled for x86_64, so this kernel
should boot fine without 'nohpet'. The original problem still remains, though.
Comment 26 Dave Jones 2007-07-29 23:58:46 EDT
upstream patch (which still isn't applied fixed this problem allegedly).
I'll look at merging it again soon, if it reoccurs, reopen, but it's very likely
to be fixed now.
Comment 27 Chuck Ebbert 2007-08-31 19:01:52 EDT
Do we still need this in 2.6.22 kernels?
Comment 28 Thorsten Leemhuis 2007-09-01 05:10:58 EDT
(In reply to comment #27)
> Do we still need this in 2.6.22 kernels?

this as in "nohpet"? No, afaics it should not be needed normally:

- the bug in question was fixed in rawhide
- 2.6.22-x86_64 in F7 is not tickless, which was the culprit for this bug
Comment 29 drago01 2007-09-01 06:02:16 EDT
current tickless kernels (rawhide) boot fine on my x86_64 boxes.
f7 x86_64 is not tickless so no issue here.

Note You need to log in before you can comment on or make changes to this bug.