Bug 247348 - "USB" stick neither detected nor mounted
Summary: "USB" stick neither detected nor mounted
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FCMETA_USB
TreeView+ depends on / blocked
 
Reported: 2007-07-07 13:23 UTC by Joachim Frieben
Modified: 2008-01-09 18:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 18:34:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "dmesg" after booting system with inserted "USB" stick (15.38 KB, text/plain)
2007-07-07 13:26 UTC, Joachim Frieben
no flags Details
Additonal "dmesg" entries after loading "usb-storage.ko" during boot. (488 bytes, text/plain)
2007-07-07 13:27 UTC, Joachim Frieben
no flags Details
Output of "lspci -vv" for "PR400FX" based system (4.11 KB, text/plain)
2007-07-07 13:28 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2007-07-07 13:23:55 UTC
Description of problem:
After plugging a "USB" stick into one of the two "USB" ports of my "PR440FX"
based system, nothing happens. No drive icon appears on the desktop, and
there is no trace in the output of "dmesg" either.

Version-Release number of selected component (if applicable):
gnome-volume-manager-2.17.0-7.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Log in to "GNOME" session.
2. Insert "USB" stick.
  
Actual results:
None.

Expected results:
"USB" stick gets detected and auto-mounted.

Additional info:
The "USB" ports of the chipset get detected and initialized. However,
there is an error message in the "dmesg" output:

  "libusual: modprobe for usb-storage succeeded, but module is not
   present"

After manual loading of "usb-storage.ko" still no improvement. I have
to unload "uhci-hcd.ko" and to reload it again, in order to obtain the
following entry in the "dmesg" output:

  "sd 3:0:0:0: Attached scsi removable disk sdb".

Now "/dev"sdb1" has been created, but the stick still does not get
mounted automatically. After mounting "/dev/sdb1" by hand, the stick
is accessible, but there is still no icon on the desktop. On my not
really recent "IBM ThinkPad T23" running the "development" tree, the
stick gets automounted as expected.

Comment 1 Joachim Frieben 2007-07-07 13:26:13 UTC
Created attachment 158717 [details]
Output of "dmesg" after booting system with inserted "USB" stick

Comment 2 Joachim Frieben 2007-07-07 13:27:47 UTC
Created attachment 158718 [details]
Additonal "dmesg" entries after loading "usb-storage.ko" during boot.

Comment 3 Joachim Frieben 2007-07-07 13:28:43 UTC
Created attachment 158719 [details]
Output of "lspci -vv" for "PR400FX" based system

Comment 4 Joachim Frieben 2007-07-07 13:36:13 UTC
The system is a current "F7" one with all updates as of 2007-07-07.

Comment 5 Joachim Frieben 2007-07-09 07:49:17 UTC
After installing "testing" updates as of 2007-07-08 including kernel
"2.6.21-1.3255.fc7", the "USB" stick gets detected when it has been
inserted -before- booting the system which is a certain progress.
Upon logging in to "GNOME", the stick is mounted as "/media/disk",
and a drive icon appears on the desktop as expected! It is also
possible to unmount the device via the context menu.
However, after unmounting, removing and reinserting the stick, it is
still necessary to un- and reload "uhci-hcd.ko" in order to get a
device created for it. Even after this has happened, the device still
does not get mounted.

Comment 6 Joachim Frieben 2007-07-09 17:57:40 UTC
After adding "noapic" to the kernel options, the "USB" stick is
auto-mounted as expected, and the write rate increases from about
20 KB/s to almost 1300 KB/s. The problem is thus related
to the interrupt handling of the "USB 1.x" device

Comment 7 David Zeuthen 2007-07-09 18:30:36 UTC
You forgot to reassign the owner as well...

Comment 8 Joachim Frieben 2007-07-16 07:24:55 UTC
This not a "Fedora" specific issue, as it also occurs with a current "Ubuntu 
7.10" development snapshot, and as here, adding "noapic" to the kernel boot 
options restores proper working.

Comment 9 Christopher Brown 2007-09-16 20:44:57 UTC
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris

Comment 10 Joachim Frieben 2007-09-18 20:22:17 UTC
Issue still present for current development tree kernel version
2.6.23-0.184.rc6.git4.fc8.

Comment 11 Christopher Brown 2007-09-18 21:39:19 UTC
Okay, thanks for testing Joachim. I'm copying this to the USB subsystem
maintainer and adding a USB blocker bug. Hopefully this will generate further
review and resolve the problem for you faster.

Cheers
Chris

Comment 12 Christopher Brown 2008-01-09 15:51:49 UTC
Joachim,

Can I get an update from you on this - are you still having this issue?

Comment 13 Joachim Frieben 2008-01-09 18:22:05 UTC
I have changed my desktop system and do not know when I will be able to
retest this issue. The non-ACPI PR440FX mainboard from 1996 is probably
not of real interest for a wider audience anymore. Closing as WONTFIX?

Comment 14 Christopher Brown 2008-01-09 18:34:43 UTC
Okay, thanks for the update Joachim. Will close CANTFIX as you don't have the
hardware any more...


Note You need to log in before you can comment on or make changes to this bug.