Bug 247361 - Kernel kernel-2.6.21-1.3255.fc7.i686 from updates testing does not boot
Kernel kernel-2.6.21-1.3255.fc7.i686 from updates testing does not boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-07 17:54 EDT by Stephen Moehle
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-13 13:58:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output from Dell D820 that won't boot with F7 test kernel (19.13 KB, text/plain)
2007-07-10 02:42 EDT, Paul Johnson
no flags Details
Attached is the LSPCI output for my Dell D620 failing to boot with kernel 2.6.21-1.3255. Tried with hpet=disabled... works... without it. Hangs at the same place. (17.36 KB, text/plain)
2007-07-13 13:26 EDT, James Allerton-Austin
no flags Details

  None (edit)
Description Stephen Moehle 2007-07-07 17:54:49 EDT
Kernel kernel-2.6.21-1.3255.fc7.i686 from updates testing does not boot on my
Dell Latitude D820 laptop with an Intel Core 2 Duo processor.

It gets to the following and hangs:
checking if image in initramfs...<6>Switched to high resoulutin CPU1
Switched to high resoulution CPU 0
  it is
Freeing initrd memory: 2825k freed.

Kernel command line is: "ro root=/dev/sda8"
Comment 1 Stephen Moehle 2007-07-08 15:33:53 EDT
Adding "hped=disabled" to the kernel command line allows it to boot. This was
not necessary with 3228.
Comment 2 Chuck Ebbert 2007-07-09 18:23:57 EDT
We now have two reports of Latitude D820 not booting, no other hardware
type has been reported with this problem.
Comment 3 Paul Johnson 2007-07-10 02:42:28 EDT
Created attachment 158826 [details]
lspci output from Dell D820 that won't boot with F7 test kernel
Comment 4 Paul Johnson 2007-07-10 02:45:59 EDT
I have one of these D820 and have this problem.  With hpet=disabled, it will
start and suspend/resume work great.  

I just installed smolt and ran smoltSendProfile: my hardware information is here:

http://smolt.fedoraproject.org/show?UUID=b78898cd-f203-442a-8d82-53fc8b900962

I'm attaching a text file with the output from lspci -vvv, since it looks a bit
more informative than smolt.

The only thing is this: I don't think the original F7 kernel booted on this
system either.  But the update was posted by the time I installed F7, so I never
worried about it.  If I had been paying attention, maybe I could say.  I'm
pretty sure it was that same thing where it recognizes the 2 cpus and then stops
with some crapola about iomem ports.
Comment 5 Todd Zullinger 2007-07-11 16:10:06 EDT
I've got a Dell Inspiron 9400/E1705 that fails to boot 2.6.21-1.3255.fc7 without
hpet=disabled.  This is the first kernel I've had this problem with.  I did just
update my bios, which may have helped trigger this.  I updated the bios before I
installed 3255, so I can't say for sure.  3228 still boots fine without any hpet
line.

Profile is here:
http://smolt.fedoraproject.org/show?UUID=60b9260f-bce5-4953-9e7c-1d8dc98e5cf4
Comment 6 James Allerton-Austin 2007-07-13 13:26:29 EDT
Created attachment 159217 [details]
Attached is the LSPCI output for my Dell D620 failing to boot with kernel 2.6.21-1.3255. 
Tried with hpet=disabled... works... without it. Hangs at the same place.
Comment 7 Stephen Moehle 2007-07-13 13:40:14 EDT
kernel-2.6.22-2.fc7.i686.rpm from Dave Jone's work-in-progress kernel page boots
OK for me without having to disable HPET. Suspend/resume even works! If that is
going to be the basis for the next F7 update, this bug can be closed.
Comment 8 Chuck Ebbert 2007-07-13 13:58:59 EDT
kernel-2.6.22.1-20.fc7 has been submitted for pushing to updates-testing.
It should be available shortly as a testing update.
Comment 9 Kevin Fenzi 2007-07-13 18:18:05 EDT
2.6.22.1-20.fc7 works fine on my D820. I did run into the hpet issue with some
kernels there, but otherwise it's worked just fine. F7 install worked fine. 

Are all the other reporters using the i686 kernel? 
I am using the x86_64 kernel. Perhaps thats related to the issue?
Comment 10 Paul Johnson 2007-07-14 14:07:23 EDT
Good news.  I just installed the test version 2.6.22-2.fc7 from the Dave Jones
test kernel web site
(http://people.redhat.com/davej/kernels/Fedora/fc7/RPMS.kernel/i386/) and the
D820 DOES boot. Furthermore, there is extremely promising information about the
hpet support in the messages.  

BEHOLD:
Jul 14 12:49:29 pols126 kernel: hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0        
                                Jul 14 12:49:29 pols126 kernel: hpet0: 3 64-bit
timers, 14318180 Hz                                             Jul 14 12:49:29
pols126 kernel: Calibrating delay using timer specific routine.. 4664.19
BogoMIPS (lpj=2332
[snip]


Jul 14 12:49:29 pols126 kernel: SMP alternatives: switching to UP code         
                                Jul 14 12:49:29 pols126 kernel: ACPI: Core
revision 20070126                                                    Jul 14
12:49:29 pols126 kernel: CPU0: Intel(R) Core(TM)2 CPU         T7600  @ 2.33GHz
stepping 06               Jul 14 12:49:29 pols126 kernel: SMP alternatives:
switching to SMP code                                         Jul 14 12:49:29
pols126 kernel: Booting processor 1/1 eip 3000                                 
                Jul 14 12:49:29 pols126 kernel: CPU 1 irqstacks, hard=c0795000
soft=c0775000                                    Jul 14 12:49:29 pols126 kernel:
Initializing CPU#1                                                             
Jul 14 12:49:29 pols126 kernel: Calibrating delay using timer specific routine..
4660.43 BogoMIPS (lpj=2330216) Jul 14 12:49:29 pols126 kernel: monitor/mwait
feature present.                                                  Jul 14
12:49:29 pols126 kernel: CPU: L1 I cache: 32K, L1 D cache: 32K                 
                         Jul 14 12:49:29 pols126 kernel: CPU: L2 cache: 4096K  
                                                         Jul 14 12:49:29 pols126
kernel: CPU: Physical Processor ID: 0                                          
        Jul 14 12:49:29 pols126 kernel: CPU: Processor Core ID: 1              
                                        Jul 14 12:49:29 pols126 kernel: Intel
machine check architecture supported.                                     Jul 14
12:49:29 pols126 kernel: Intel machine check reporting enabled on CPU#1.       
                         Jul 14 12:49:29 pols126 kernel: CPU1: Intel(R)
Core(TM)2 CPU         T7600  @ 2.33GHz stepping 06               Jul 14 12:49:29
pols126 kernel: Total of 2 processors activated (9324.62 BogoMIPS).            
                Jul 14 12:49:29 pols126 kernel: ENABLING IO-APIC IRQs          
                                  
Jul 14 12:49:29 pols126 kernel: ..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
Jul 14 12:49:29 pols126 kernel: checking TSC synchronization [CPU#0 -> CPU#1]:
Jul 14 12:49:29 pols126 kernel: Measured 4852699432 cycles TSC warp between
CPUs, turning off TSC clock.
Jul 14 12:49:29 pols126 kernel: Marking TSC unstable due to:
check_tsc_sync_source failed.
Jul 14 12:49:29 pols126 kernel: Brought up 2 CPUs
Jul 14 12:49:29 pols126 kernel: Time: 12:49:03  Date: 06/14/107
Jul 14 12:49:29 pols126 kernel: NET: Registered protocol family 16
Jul 14 12:49:29 pols126 kernel: ACPI: bus type pci registered
Jul 14 12:49:29 pols126 kernel: PCI: Using MMCONFIG
Jul 14 12:49:29 pols126 kernel: Setting up standard PCI resources
Jul 14 12:49:29 pols126 kernel: ACPI Warning (tbutils-0158): Incorrect checksum
in table [TCPA] -  00, should be 9B [20070126]
Jul 14 12:49:29 pols126 kernel: ACPI: SSDT 3FE8198C, 0043 (r1  LMPWR  DELLLOM  
  1001 INTL 20050624)
Jul 14 12:49:29 pols126 kernel: ACPI: Interpreter enabled
Jul 14 12:49:29 pols126 kernel: ACPI: (supports S0 S3 S4 S5)
Jul 14 12:49:29 pols126 kernel: ACPI: Using IOAPIC for interrupt routing

[snip]
Jul 14 12:49:29 pols126 kernel: Time: hpet clocksource has been installed.
Jul 14 12:49:29 pols126 kernel: Switched to high resolution mode on CPU 0
Jul 14 12:49:29 pols126 kernel: pnp: 00:02: ioport range 0x1000-0x1005 has been
reserved
Jul 14 12:49:29 pols126 kernel: pnp: 00:02: ioport range 0x1008-0x100f has been
reserved
Jul 14 12:49:29 pols126 kernel: Switched to high resolution mode on CPU 1
Jul 14 12:49:29 pols126 kernel: pnp: 00:03: ioport range 0xf400-0xf4fe has been
reserved
Jul 14 12:49:29 pols126 kernel: pnp: 00:03: ioport range 0x1006-0x1007 has been
reserved

And it goes on from there, starts find.  I'm not testing suspend until I want a
full cold start, if you know what I mean :)

This last part is where the boot up fell dead with the previous test kernel.

Thanks to Dave for his effort

Note You need to log in before you can comment on or make changes to this bug.