Bug 247383 - Erroneous tifm_core: MMC/SD card detected in socket 0:0
Erroneous tifm_core: MMC/SD card detected in socket 0:0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-08 10:43 EDT by Garry T. Williams
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 18:05:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci -vxxx (15.04 KB, text/plain)
2007-09-18 05:24 EDT, Garry T. Williams
no flags Details
dmesg (2.6.23.9-85.fc8) (22.19 KB, text/plain)
2008-01-09 17:40 EST, Garry T. Williams
no flags Details

  None (edit)
Description Garry T. Williams 2007-07-08 10:43:49 EDT
Description of problem:
At boot, module tifm_7xx1 claims to detect a card.  There is no card inserted. 
(This is a mild irritation because now suspend/resume complains about it.)

Version-Release number of selected component (if applicable):
2.6.21-1.3228.fc7

How reproducible:
Always on boot.

Steps to Reproduce:
1. Boot
2.
3.
  
Actual results:
Message kernel: tifm_7xx1: sd card detected in socket 0

Expected results:
No card detected in empty slot.

Additional info:
Machine is Sony Vaio VGN FS640/W.  No such problem on FC6 w/latest FC6 kernel
about one month ago.

dmesg context:
--------------

intel_rng: FWH not detected
cs: IO port probe 0x100-0x3af: clean.
cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
cs: IO port probe 0x820-0x8ff: clean.
cs: IO port probe 0xc00-0xcf7: clean.
cs: IO port probe 0xa00-0xaff: clean.
ACPI: PCI Interrupt 0000:00:1f.3[B] -> GSI 19 (level, low) -> IRQ 18
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 16 (level, low) -> IRQ 16
sr0: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
ACPI: PCI Interrupt 0000:06:03.3[B] -> GSI 17 (level, low) -> IRQ 20
tifm_7xx1: sd card detected in socket 0
e100: Intel(R) PRO/100 Network Driver, 3.5.17-k2-NAPI
e100: Copyright(c) 1999-2006 Intel Corporation
Comment 1 Christopher Brown 2007-09-17 17:12:16 EDT
Hello Garry,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 2 Garry T. Williams 2007-09-17 18:51:37 EDT
Thanks for the attention.  :-)

Yes, the bug is still present with 2.6.22.5-76.fc7.  The indicator for me is an
LED is turned on to indicate a card present.  The log message now is:

    tifm_core: MMC/SD card detected in socket 0:0

Again, the only problem is the LED light turned on and the message that I cannot
remount external storage after waking from suspend to memory.  I have no card to
insert into the slot and don't plan to acquire one, so I doubt that there is any
other problem I will see as a consequence of this bug.

If I can help with any other diagnostic information, please let me know.
Comment 3 Christopher Brown 2007-09-18 04:33:37 EDT
Try:

# echo "blacklist tifm_core" >> /etc/modprobe.d/blacklist

which should stop the pesky module from loading at boot. However if you could
post output from lspci -vvxx I'd be intrigued to see what it thinks is the TI card.

Cheers
Chris
Comment 4 Garry T. Williams 2007-09-18 05:24:39 EDT
Created attachment 198261 [details]
Output of lspci -vxxx
Comment 5 Christopher Brown 2007-09-18 07:17:19 EDT
Cheers Garry. Here it is:

06:03.3 Mass storage controller: Texas Instruments PCI7420/7620 Combo CardBus,
1394a-2000 OHCI and SD/MS-Pro Controller
	Subsystem: Sony Corporation Unknown device 8190

I need one last bit of info. Can you attach the output of lsmod as well.

Cheers
Chris
Comment 6 Garry T. Williams 2007-09-18 09:39:57 EDT
No problem:

$ lsmod
Module                  Size  Used by
arc4                    6209  2 
ecb                     7617  2 
blkcipher              10437  1 ecb
ieee80211_crypt_wep     9281  1 
i915                   27073  2 
drm                    80085  3 i915
autofs4                24773  2 
sunrpc                161981  1 
nf_conntrack_netbios_ns     7105  0 
nf_conntrack_ipv4      15049  2 
xt_state                6593  2 
nf_conntrack           63049  3 nf_conntrack_netbios_ns,nf_conntrack_ipv4,xt_state
nfnetlink               9945  2 nf_conntrack_ipv4,nf_conntrack
ipt_REJECT              8641  2 
iptable_filter          7105  1 
ip_tables              16517  1 iptable_filter
xt_tcpudp               7233  10 
ip6t_REJECT             9537  2 
ip6table_filter         6849  1 
ip6_tables             17669  1 ip6table_filter
x_tables               18629  6
xt_state,ipt_REJECT,ip_tables,xt_tcpudp,ip6t_REJECT,ip6_tables
cpufreq_ondemand       12237  1 
acpi_cpufreq           14537  0 
dm_multipath           21961  0 
video                  21065  0 
sony_acpi               9612  0 
sbs                    22729  0 
button                 12113  0 
dock                   13921  0 
battery                14149  0 
ac                      9285  0 
ipv6                  277957  41 ip6t_REJECT
snd_hda_intel         243545  1 
snd_seq_dummy           7877  0 
tifm_sd                14537  0 
mmc_core               30149  1 tifm_sd
snd_seq_oss            33473  0 
snd_seq_midi_event     11073  1 snd_seq_oss
firewire_ohci          20801  0 
snd_seq                50609  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
ipw2200               142217  0 
snd_seq_device         11981  3 snd_seq_dummy,snd_seq_oss,snd_seq
ieee80211              35593  1 ipw2200
e100                   38349  0 
firewire_core          43137  1 firewire_ohci
snd_pcm_oss            43457  0 
ieee80211_crypt        10049  2 ieee80211_crypt_wep,ieee80211
snd_mixer_oss          19521  1 snd_pcm_oss
tifm_7xx1              11457  0 
mii                     9409  1 e100
snd_pcm                74949  2 snd_hda_intel,snd_pcm_oss
crc_itu_t               6337  1 firewire_core
tifm_core              14405  2 tifm_sd,tifm_7xx1
i2c_i801               12369  0 
snd_timer              24901  2 snd_seq,snd_pcm
iTCO_wdt               14693  0 
rtc_cmos               12001  0 
serio_raw              10821  0 
i2c_core               27841  1 i2c_i801
snd                    53317  10
snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
iTCO_vendor_support     7877  1 iTCO_wdt
soundcore              11681  1 snd
snd_page_alloc         13769  2 snd_hda_intel,snd_pcm
joydev                 13825  0 
sr_mod                 20837  0 
cdrom                  37089  1 sr_mod
sg                     37469  0 
dm_snapshot            20709  0 
dm_zero                 6209  0 
dm_mirror              25153  0 
dm_mod                 56833  13 dm_multipath,dm_snapshot,dm_zero,dm_mirror
ata_piix               18757  2 
ata_generic            11589  0 
libata                117809  2 ata_piix,ata_generic
sd_mod                 31297  3 
scsi_mod              140749  4 sr_mod,sg,libata,sd_mod
ext3                  125513  4 
jbd                    59881  1 ext3
mbcache                12485  1 ext3
ehci_hcd               35405  0 
ohci_hcd               23877  0 
uhci_hcd               27089  0
$
Comment 7 Christopher Brown 2007-09-18 10:14:25 EDT
Bingo!

mmc_core               30149  1 tifm_sd
tifm_sd                14537  0 

# echo "blacklist mmc_core" >> /etc/modprobe.d/blacklist
# echo "blacklist tifm_sd" >> /etc/modprobe.d/blacklist

and your troubles should be over. Then remove the blacklisting when 2.6.23
arrives and re-try.

Cheers
Chris
Comment 8 Garry T. Williams 2007-09-18 18:17:00 EDT
I disabled the module by adding this to /etc/modprobe.conf:

    install tifm_core /bin/false

Now the laptop boots without turning on the LED and will suspend and resume
without the warning about the non-existent card not being remounted.

Thanks.

I will re-try on the .23 kernel when it's available and post an update to this bug.
Comment 9 Garry T. Williams 2007-10-13 10:15:52 EDT
I removed the "install tifm_core /bin/false" from /etc/modprobe.conf and
installed the 2.6.23-1.fc7 kernel from updates-testing.

dmesg shows:

    tifm_core: MMC/SD card detected in socket 0:0

The LED is turned on and after a resume from suspend to memory, I receive a
message (unable to remount (all) external storage media) from the KDE desktop.

I will continue to use the work-around (disabling the load of the module).  The
desktop message upon resume continues to show up in spite of disabling the load
of the module.  The LED is turned off, though.
Comment 10 Christopher Brown 2008-01-09 10:58:47 EST
Hello Garry,

Are you still having to disable the tifm_core module to sus/res with the latest
kernels? Any chance you can try 2.6.24 and report back when it arrives?
Comment 11 Garry T. Williams 2008-01-09 17:20:04 EST
Yes, the LED still turns on.  I still get a desktop notification 
"unable to remount..." after resume from suspend to memory.

I have just been ignoring all of this but, to be complete, I get this
behavior with 2.6.23.9-85.fc8 and I see no later kernel in
updates-testing.  As soon as I can install the 2.6.24 kernel, I'll
test again and report back.
Comment 12 Garry T. Williams 2008-01-09 17:40:56 EST
Created attachment 291212 [details]
dmesg (2.6.23.9-85.fc8)

Just in case it's relevant, here's my latest dmesg.
Comment 13 Christopher Brown 2008-01-09 18:49:36 EST
The module gets loaded followed by:

tifm_sd: Unknown symbol mmc_request_done
tifm_sd: Unknown symbol mmc_remove_host
tifm_sd: Unknown symbol mmc_alloc_host
tifm_sd: Unknown symbol mmc_add_host
tifm_sd: Unknown symbol mmc_suspend_host
tifm_sd: Unknown symbol mmc_resume_host
tifm_sd: Unknown symbol mmc_free_host

I think your best bet is to test with 2.6.24 when that arrives (or as previously
indicated from rawhide) as a large number of fixes have entered the tree. If you
could do so and report back that would be appreciated.
Comment 14 Garry T. Williams 2008-01-19 16:22:41 EST
I know it's not 2.6.24, but I saw that updates-testing had 2.6.23.14-107.fc8 and
installed it.  Still no joy.  I'll report when I have tested 2.6.24.
Comment 15 Garry T. Williams 2008-03-03 18:05:42 EST
I installed 2.6.24.2-7.fc8 from updates-testing.

No joy.

Here's information from dmesg (this is FC8, yum upgraded from FC7):

tifm_core: MMC/SD card detected in socket 0:0
tifm_sd: Unknown symbol mmc_request_done
tifm_sd: Unknown symbol mmc_remove_host
tifm_sd: Unknown symbol mmc_alloc_host
tifm_sd: Unknown symbol mmc_add_host
tifm_sd: Unknown symbol mmc_suspend_host
tifm_sd: Unknown symbol mmc_resume_host
tifm_sd: Unknown symbol mmc_free_host

I mentioned before that I have no card in this slot.  I have never owned such a
card.

To summarize, the effect of this bug is two-fold:

1.  On my laptop (Sony Vaio VGNFS640W), an LED lights up to indicate a card is
inserted.

2.  Wake up from suspend to memory is accompanied by a "pop-up" message on the
KDE desktop that complains about not being able to remount the media (that I
never had mounted in the first place).

These symptoms are quite benign and are only a minor irritation.  I don't
anticipate ever purchasing an actual card for this slot, so I don't suppose that
I'll ever see any other symptoms.  Actually, I'll probably disable the loading
of that module and forget about this.  :-)

Unless you have any other diagnostics I could perform on this system, I suppose
you can close this bug as WONTFIX, CANTFIX, NOTABUG, ???.

Note You need to log in before you can comment on or make changes to this bug.