Bug 247387 - f7 xen won't boot fc6 xen kernel on x86_64
f7 xen won't boot fc6 xen kernel on x86_64
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Eduardo Habkost
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-08 14:30 EDT by Erik Logtenberg
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 00:16:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Erik Logtenberg 2007-07-08 14:30:20 EDT
I tried running a Fedora Core 6 Xen kernel [1] on a Fedora 7 [2] dom0 on a Core
2 Duo machine (x86_64). The "xm create -c domain.conf" command doesn't seem to
do much, for some time the domain shows up in "xm list", but in the end it
doesn't boot, and the xm create command keeps hanging without giving output,
until finally being killed.

[1] fedora/core/6/x86_64/os/images/xen/vmlinuz and initrd.img
[2] 2.6.20-2925.11.fc7xen

The exact same combination using an i386 Fedora 7 dom0 and an i386 Fedora Core 6
domU works like a charm with no problems at all (on that same machine,
configured identically).

Strace'ing the xm create process didn't give me much hints that I could
understand either. Any steps that I could take to further narrow the problem down?
I also tried using the Fedora Core 5 Xen image, and it gave the exact same result.
Comment 1 Richard W.M. Jones 2007-07-13 07:21:32 EDT
Is this fullvirt or paravirt?

FWIW I can run FC6 paravirt kernels just fine in F7 dom0.  However
there is currently a problem with SELinux which prevents them from
connecting network devices to the bridge, so you should turn
SELinux to permissive mode first.  (Bug 243219 and bug 245274).
Comment 2 Eduardo Habkost 2007-09-24 16:59:16 EDT
I couldn't reproduce it here, either:

With a FC-6 DVD is mounted on /mnt/cdrom:

[root@F7-64 ~]# cat /tmp/fc6.conf
kernel = '/mnt/cdrom/images/xen/vmlinuz'
initrd = '/mnt/cdrom/images/xen/initrd.img'
[root@F7-64 ~]# xm create -c /tmp/fc6.conf
Using config file "/tmp/fc6.conf".
Started domain fc6.conf
Bootdata ok (command line is )
Linux version 2.6.18-1.2798.fc6xen (brewbuilder@hs20-bc1-6.build.redhat.com) 
(gcc version 4.1.1 20061011 (Red Hat 4.1.1-30)) #1 SMP Mon Oct 16 14:59:01 EDT 
2006
[...]


My dom0 was running kernel-xen 2.6.20-2936.fc7xen.

Could you show the contents of the domain.cfg file you are using to reproduce 
the problem?
Comment 3 Brian Powell 2008-04-25 00:16:59 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "CLOSED INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note that maintenance for Fedora 7 will end 30 days after the GA of Fedora 9.

Note You need to log in before you can comment on or make changes to this bug.