Bug 247389 - hidd start always fails
hidd start always fails
Status: CLOSED DUPLICATE of bug 230017
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-07-08 14:57 EDT by Justin Dick
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-21 06:51:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Justin Dick 2007-07-08 14:57:53 EDT
Description of problem:
The startup of hidd consistently fails on boot and when manually restarting the
component.  The error given is
   "Can't listen on HID control channel: Address already in use"
Stopping hcid and sdpd, restarting hidd, and restarting hcid and sdpd allows a
successful restart, but it does not appear that hidd can actually make
connections to bluetooth HID devices.

Version-Release number of selected component (if applicable):

How reproducible:
This happens every time on boot.  Alternatively:

Steps to Reproduce:
1. sudo /etc/init.d/hidd stop
2. sudo /usr/bin/hidd -n --server
Actual results:
Can't listen on HID control channel: Address already in use
Comment 1 David Woodhouse 2007-07-21 06:51:15 EDT

*** This bug has been marked as a duplicate of 230017 ***

Note You need to log in before you can comment on or make changes to this bug.