Bug 247391 - Remove extras key in F7
Remove extras key in F7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-08 16:04 EDT by Nigel Henry
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.5.15lorg3.2-12.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 13:56:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Henry 2007-07-08 16:04:43 EDT
Description of problem: 
/etc/apt/gpg has a public key installed with Apt that is pointing 
to /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-extras (gpg-pubkey-1ac70ce6-41bebeef). 
Running apt-get with this key available there are constant nags from apt that 
there are missing keys, then something like fetching keys, then unable to 
import keys. Obvious as there is no key for extras with F7. 
 
The fix is simple and only requires the removal of this key. Then apt-get no 
longer complains, but perhaps whoever is maintaining Apt for F7 could rebuild 
it so that this key is no longer included. 
 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
 
Always 
 
 
Steps to Reproduce: 
1.run apt-get update as root 
2. 
3. 
   
Actual results: 
 
No problems with installing updates, as another key is installed when you 
install apt, but there is just a bit of confusion with apt claiming there are 
missing keys, which in reality there arn't, and appears to be due to an old 
key leftover from FC6 for the extras repo which is still being included with 
Apt installed on F7 
 
 
Expected results: 
 
 
Additional info:
Comment 1 Axel Thimm 2007-07-08 16:31:03 EDT
Thanks, I missed this one!
Comment 2 Fedora Update System 2007-08-02 22:40:01 EDT
apt-0.5.15lorg3.2-12.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Axel Thimm 2007-08-03 05:31:08 EDT
apt-0.5.15lorg3.2-12.fc7 should have this fixed, can you please check? Thanks!
Comment 4 Nigel Henry 2007-08-03 13:19:29 EDT
(In reply to comment #3) 
> apt-0.5.15lo 
> g3.2-12.fc7 should have this fixed, ca 
>  you please check? Tha 
> ks! 
 
Sorry for the delay. more problems with keys. No link from /etc/apt/gpg 
to /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test. The new apt package downloaded 
ok, but failed to install because apt-get couldn't find the key. 
 
Problem resolved by creating a link (gpg-pubkey-30c9ecf8) pointing 
to /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test. 
 
So. I removed the dodgy extras key from the directory it was hidden in, and 
put it back in /etc/apt/gpg, got rid of the directory, and ran apt-get install 
apt again, and apt updated with no problems. My new link to fedora-test 
remained, and the unwanted key for fedora extras was gone. 
 
I can verify that the unwanted key for the extras repo in etc/apt/gpg on F7 
has been resolved, and that key no longer is seen with 
apt-0.5.15lorg3.2-12.fc7. 
 
Thanks for the quick fix. 
 
Nigel. 
 
btw. I know I opened the bug, but you can go ahead and close it if you want. 
 
 
 
 
 
 
 
Comment 5 Fedora Update System 2007-08-06 13:56:40 EDT
apt-0.5.15lorg3.2-12.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.