Bug 247394 - audacity requires compat-wxGTK26
audacity requires compat-wxGTK26
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-08 19:07 EDT by Evan McNabb
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 05:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evan McNabb 2007-07-08 19:07:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070603 Fedora/2.0.0.4-2.fc7 Firefox/2.0.0.4

Description of problem:
When running audacity 1.3.2-14.fc7, I got the following library error:

$ audacity 
audacity: error while loading shared libraries: libwx_gtk2u_xrc-2.6.so.0: cannot open shared object file: No such file or directory

According to the RPM changelog, it looks like this was recently changed:
* Fri Feb 23 2007 Gerard Milmeister <gemi@bluewin.ch> - 1.3.2-12
- build with wxGTK 2.6 compatibility package

I installed compat-wxGTK26 and it works as expected.

Version-Release number of selected component (if applicable):
audacity-1.3.2-14.fc7

How reproducible:
Always


Steps to Reproduce:
1. Install audacity 1.3.2-14.fc7 on minimal install. In most cases, compat-wxGTK26 will not already be installed.
2. Execute audacity
3.

Actual Results:


Expected Results:
The audacity RPM should depend on compat-wxGTK26 so it gets installed automatically by yum.



Additional info:
Comment 1 Michael Schwendt 2007-07-09 05:12:09 EDT
Please see:

$ rpm -qR audacity|grep wx

The dependency on compat-wxGTK26 _is_ there.
Yum in stock F7 is broken, however. Get at least yum-3.2.1-1.fc7,
and if the problem persists, file a ticket about yum.

Note You need to log in before you can comment on or make changes to this bug.