Bug 247399 - Exception Occurred: AttributeError: 'module' object has no attribute 'ZoneTab'
Exception Occurred: AttributeError: 'module' object has no attribute 'ZoneTab'
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-08 23:17 EDT by Rodney Smith
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:49:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodney Smith 2007-07-08 23:17:00 EDT
Description of problem:
In text-mode of installation, the installation halts with the exception:
  File "/usr/bin/anaconda", line 955, in <module
    anaconda.intf.run(anaconda)
AttributeError: 'module' object has no attribute 'ZoneTab'

How reproducible:
Every time

Steps to Reproduce:
1. boot from fc7 install dvd
2. switch to text mode
3. follow install instructions
  
Actual results:
...
  File "/usr/bin/anaconda", line 955, in <module
    anaconda.intf.run(anaconda)
AttributeError: 'module' object has no attribute 'ZoneTab'


Expected results:
an fc7 installation

Additional info:
System previously had fc5 that was installed using a dvd and the graphical
interface without a hitch and that ran fine.

Attempting to install using the graphical interface ran into the "unmount CD"
error and other unhandled python exceptions depending on which options were
chosen or the phase of the moon.  I did not record the details.  I tried the
text-install in hopes that it would be a workaround.
Comment 1 Chris Lumens 2007-07-11 22:24:57 EDT
Please attach the complete traceback report to this bug so we can see where the
problem is.  Unfortunately, the part you pasted doesn't show the call where the
AttributeError occurred, so it's not possible for me to tell what needs fixing.
Comment 2 James Newton 2008-01-21 16:23:22 EST
I encountered the same error <james.newton (at) openspark.com>.  Here are my
installation steps, plus the error traceback:


Install or upgrade an existing system (text mode)

Skip testing CD media (already tested)

language: English
keyboard: UK

Remove all partitions on selected drives and create default layout
(Only one drive available)

Confirm removal of all partitions on /dev/sda

Review and modify partitioning layout? No

Configure eth0 and eth1:
[*] Activate on boot
[*] Enable IPv4 support
    + 10-digit WEP Key

(*) Dynamic IP configuration (DHCP)

Hostname Configuration
(*) automatically via DHCP


Network configuration complete.  Long pause with no visual feedback after
selecting OK and pressing Enter.  Then:


------------------| Exception Occurred |------------------
Traceback (most recent call first):
  File
"/usr/lib/anaconda/textw/timezone_text.py",
line 33, in getTimezoneList
    zt = zonetab.ZoneTab()
  File
"/usr/lib/anaconda/textw/timezone_text.py",
line 61, in __call__
    timezones = self.getTimesoneList()
  File "/usr/lib/anaconda/text.py", line
582, in run
    rc = win(self.screen, instance)
  File "/usr/bin/anaconda", line 955, in
<module>
    anaconda.intf.run(anaconda)
AttributeError: 'module' object has no attribute 'ZoneTab'


                     [OK]    [DEBUG]

----------------------------------------------------------

Selecting OK leads to:

install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /mnt/source done
        /selinux done
you may safely reboot your system
Comment 3 Danny D'Amours 2008-04-02 16:11:04 EDT
I am seeing this behaviour as well on installing Fedora 9 Beta on an older Dell
Latitude C840 laptop.

I was able to get this error in a subsequent install by skipping the network
configuration.
Comment 4 Bug Zapper 2008-05-14 09:27:41 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Chris Lumens 2008-05-19 16:54:44 EDT
This really seems like something that could be caused by errors reading the CD
media.  Could someone who is seeing this take a look at tty4 or /tmp/syslog and
see if there are kernel read error messages?
Comment 6 Bug Zapper 2008-06-16 21:49:33 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.