This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 247411 - cannot easily change configure --prefix
cannot easily change configure --prefix
Status: CLOSED DEFERRED
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
1.1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Nathan Kinder
Ben Levenson
:
Depends On:
Blocks: 389_1.3.0
  Show dependency treegraph
 
Reported: 2007-07-09 01:23 EDT by Andrew Bartlett
Modified: 2015-11-19 17:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 17:32:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Bartlett 2007-07-09 01:23:53 EDT
Description of problem:
If I configure with one prefix, then want to change it, references to the old
prefix remain

Version-Release number of selected component (if applicable):
cvs

How reproducible:
every time

Steps to Reproduce:
1. ./configure --prefix=/scratch/fedora-ds/prefix
2. ./configure --prefix=/data/fedora-ds/prefix
3. make install
  
Actual results:
scripts like ds_newinst cannot find ds_newinst-bin

Expected results:
configure should recreate all prefix dependent files, or make should have these
depend on configure's output.

Additional info:
The only way I found out that ds_newinst wasn't in the right place was by
strace.  Very confusing for a new user building from CVS.
Comment 6 Martin Kosek 2012-01-04 08:46:36 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/130
Comment 8 Noriko Hosoi 2015-11-19 17:32:46 EST
Closing this bug since we moved to the ticket system:
https://fedorahosted.org/389/ticket/130

Note You need to log in before you can comment on or make changes to this bug.