Bug 247432 - [upgrade pending] OpenOffice Writer crashed on CTRL+C
[upgrade pending] OpenOffice Writer crashed on CTRL+C
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 06:04 EDT by markm
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 06:02:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mapped backtrace (8.83 KB, text/plain)
2007-07-11 10:17 EDT, Caolan McNamara
no flags Details

  None (edit)
Description markm 2007-07-09 06:04:31 EDT
Description of problem:

Application crashes on CTRL+C

Version-Release number of selected component (if applicable):

openoffice.org-writer 1:2.2.0-14.11@i386

How reproducible:

it happened once.

Steps to Reproduce:
1. Open a document
2. Select a title
3. press CTRL+C
  
Actual results:

application crashes

Expected results:

copy a selected text I guess

Additional info:

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.2-12-i386
(V)    kernel is: Linux 2.6.21-1.3255.fc7 #1 SMP Thu Jul 5 18:03:08 EDT 2007
i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.2.0-14.11-i386
(VII)    depth of root window:    24 planes
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora release 7 (Moonshine)
...start free space details ...
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda3             63414612  54093196   6702824  89% /home
/dev/sda2             10154020   6677172   2952728  70% /
...end free space details ...
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x0498b6df: 0x001b6374: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x206df
0x0498bfea: 0x001b6374: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x20fea
0x00110420: 0x00000000:  + 0x420 (__kernel_sigreturn + 0x0)
0x0013b8b1: 0x0014fd7c: /lib/libc.so.6 + 0x2a8b1 (abort + 0x101)
0x0475c550: 0x000e397c: /usr/lib/libstdc++.so.6 + 0xb7550
(__gnu_cxx::__verbose_terminate_handler() + 0x150)
0x0475a035: 0x000e397c: /usr/lib/libstdc++.so.6 + 0xb5035
0x0475a072: 0x000e397c: /usr/lib/libstdc++.so.6 + 0xb5072
0x0475a715: 0x000e397c: /usr/lib/libstdc++.so.6 + 0xb5715
0x0227f288: 0x0038cb50: /usr/lib/openoffice.org/program/libsvt680li.so +
0x12f288 (TransferableDataHelper::InitFormats() + 0x6a)
0x0227f7d9: 0x0038cb50: /usr/lib/openoffice.org/program/libsvt680li.so +
0x12f7d9
(TransferableDataHelper::TransferableDataHelper(com::sun::star::uno::Reference<com::sun::star::datatransfer::XTransferable>
const&) + 0x87)
0x0653818e: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x7be18e
0x00c299a4: 0x00029984: /usr/lib/openoffice.org/program/libdtransX11680li.so +
0x99a4
0x00c29bd6: 0x00029984: /usr/lib/openoffice.org/program/libdtransX11680li.so +
0x9bd6
0x02280354: 0x0038cb50: /usr/lib/openoffice.org/program/libsvt680li.so +
0x130354 (TransferableHelper::CopyToClipboard(Window*) const + 0x208)
0x06439536: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x6bf536
0x0643d300: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x6c3300
0x02948621: 0x002fe478: /usr/lib/openoffice.org/program/libsfx680li.so + 0xe7621
(sfx2::SvLinkSource::NotifyDataChanged() + 0xaf)
0x06196028: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x41c028
0x06196107: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x41c107
0x0614df7d: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x3d3f7d
0x06150f1f: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x3d6f1f
0x05f7afab: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x200fab
0x05f7b169: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x201169
(SwEditShell::Delete() + 0x107)
0x06542b7b: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x7c8b7b
(SwWrtShell::DelRight(unsigned char) + 0xef)
0x06438c1a: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x6bec1a
0x064418d4: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x6c78d4
0x0647ee95: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x704e95
0x0647f24f: 0x0089faa4: /usr/lib/openoffice.org/program/libsw680li.so + 0x70524f
0x02a3f9c3: 0x002fe478: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1de9c3
0x02a3ff24: 0x002fe478: /usr/lib/openoffice.org/program/libsfx680li.so +
0x1def24 (SfxDispatcher::_Execute(SfxShell&, SfxSlot const&, SfxRequest&,
unsigned short) + 0x150)
0x02a362ad: 0x002fe478: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1d52ad
0x02a545f8: 0x002fe478: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1f35f8
0x02a54b63: 0x002fe478: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1f3b63
0x02269d20: 0x0038cb50: /usr/lib/openoffice.org/program/libsvt680li.so + 0x119d20
0x02269dd9: 0x0038cb50: /usr/lib/openoffice.org/program/libsvt680li.so + 0x119dd9
0x07b6e350: 0x002f60dc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x272350
0x07b1d380: 0x002f60dc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x221380
0x0099a5ad: 0x000697d0: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x465ad (SalDisplay::DispatchInternalEvent() + 0x83)
0x00842a73: 0x00041090: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x11a73
0x00842aa2: 0x00041090: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x11aa2
0x073c28c1: 0x0009d19c: /lib/libglib-2.0.so.0 + 0x298c1
0x073c4622: 0x0009d19c: /lib/libglib-2.0.so.0 + 0x2b622 (g_main_context_dispatch
+ 0x182)
0x073c75ff: 0x0009d19c: /lib/libglib-2.0.so.0 + 0x2e5ff
0x073c7b65: 0x0009d19c: /lib/libglib-2.0.so.0 + 0x2eb65
(g_main_context_iteration + 0x65)
0x0084285f: 0x00041090: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x1185f
0x0099fd15: 0x000697d0: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x4bd15 (X11SalInstance::Yield(bool, bool) + 0x2f)
0x0799d5b9: 0x002f60dc: /usr/lib/openoffice.org/program/libvcl680li.so + 0xa15b9
(Application::Yield(bool) + 0x57)
0x0799d677: 0x002f60dc: /usr/lib/openoffice.org/program/libvcl680li.so + 0xa1677
(Application::Execute() + 0x2b)
0x0371f42d: 0x00047a0c: /usr/lib/openoffice.org/program/libsoffice.so + 0x2542d
(desktop::Desktop::Main() + 0x1ae1)
0x079a1cb9: 0x002f60dc: /usr/lib/openoffice.org/program/libvcl680li.so + 0xa5cb9
0x079a1e05: 0x002f60dc: /usr/lib/openoffice.org/program/libvcl680li.so + 0xa5e05
(SVMain() + 0x2d)
0x03713bea: 0x00047a0c: /usr/lib/openoffice.org/program/libsoffice.so + 0x19bea
(main + 0x7e)
0x00126f70: 0x0014fd7c: /lib/libc.so.6 + 0x15f70 (__libc_start_main + 0xe0)
0x080484c1: 0x000006d8: /usr/lib/openoffice.org/program/swriter.bin + 0x4c1
(main + 0x5d)
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x001b4000)
	libuno_sal.so.3 => /usr/lib/openoffice.org/program/libuno_sal.so.3 (0x00c9a000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org/program/libuno_salhelpergcc3.so.3 (0x003f4000)
	libstore.so.3 => /usr/lib/openoffice.org/program/libstore.so.3 (0x00110000)
	libdl.so.2 => /lib/libdl.so.2 (0x00126000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x00ea4000)
	libstlport_gcc.so => /usr/lib/openoffice.org/program/libstlport_gcc.so (0x00a6b000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00727000)
	libm.so.6 => /lib/libm.so.6 (0x0096d000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x0012b000)
	libc.so.6 => /lib/libc.so.6 (0x003f9000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x0069d000)
	/lib/ld-linux.so.2 (0x80000000)
...end sample ldd details ...
Comment 1 Caolan McNamara 2007-07-09 06:16:07 EDT
Yeah, the stack confirms a cut and paste problem. Can you get it to happen again ?
Having the nvidia driver installed always makes me nervous.
Comment 2 markm 2007-07-09 06:20:42 EDT
I've tried but I couldn't. As I am working on a documentation right now and
using writer quite a lot, I might be able to reproduce it.

Unfortunately I can't have desktop effects without nvidia driver :)
Comment 3 Caolan McNamara 2007-07-09 12:49:56 EDT
I can't reproduce this, or get any warnings out of valgrind when cutting and
pasting stuff. Strange one.
Comment 4 markm 2007-07-09 12:53:46 EDT
I've been working all day today at this document and it didn't happen again.
Comment 5 Caolan McNamara 2007-07-11 10:17:42 EDT
Created attachment 158953 [details]
mapped backtrace
Comment 6 Caolan McNamara 2007-07-20 07:30:19 EDT
I think we should push a 2.2.1 for F-7 in the next month or two which should
pick up on some fixes. At that stage we'll close this and reopen if it ever
reappears.

Note You need to log in before you can comment on or make changes to this bug.