The current yum-metadata-parser package (1.1.0-2) has a line "Conflicts: yum <
2.6.2". However, if you install it on a system with yum 3.0.x (Fedora Core 6,
CentOS 5), you'll get a traceback.
I'm not sure exactly where the problem falls (it seems to be sqlite related,
actually) but there's definitely a problem with just this package and the newer yum.
Not urgent, but good to have.
refiling against fc6 since this isn't a rawhide bug, is it?
what's wrong with the ver of y-m-p in fc6 or c5?
Well, the issue is with the new package -- it doesn't work with the older yum.
The old package and the old yum work fine together. (As one would expect.)
Nothing is wrong with the old y-m-p, except it doesn't work with newer yum.
And also, nothing is really wrong with the new package, except if one tries to
upgrade it for some reason one might be in for a surprise.
The issue I'm envisioning where this could be a real world problem is someone
trying to do a yum-based upgrade from FC6 or CentOS 5 to a newer version. For
various reasons this is sometimes best accomplished in chunks of packages rather
than all at once -- and if one happens to upgrade this before upgrading yum,
then yum is hosed. (And doing so might seem like a sensible thing to do, because
one might try to get yum's deps in place before upgrading yum itself, to avoid
the opposite problem that happened a while ago where an upgraded version of yum
would hang if you hadn't first upgraded python-sqlite.)
Committed to CVS, will get picked up the next time there's a build
Sounds good. Thanks.