This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 247451 - should be: Conflicts: yum < 3.2.0
should be: Conflicts: yum < 3.2.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum-metadata-parser (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 08:11 EDT by Matthew Miller
Modified: 2014-01-21 17:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 09:49:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2007-07-09 08:11:21 EDT
The current yum-metadata-parser package (1.1.0-2) has a line "Conflicts: yum <
2.6.2". However, if you install it on a system with yum 3.0.x (Fedora Core 6,
CentOS 5), you'll get a traceback.


I'm not sure exactly where the problem falls (it seems to be sqlite related,
actually) but there's definitely a problem with just this package and the newer yum.

Not urgent, but good to have.
Comment 1 Seth Vidal 2007-07-09 08:19:22 EDT
refiling against fc6 since this isn't a rawhide bug, is it?
what's wrong with the ver of y-m-p in fc6 or c5?
Comment 2 Matthew Miller 2007-07-09 09:44:32 EDT
Well, the issue is with the new package -- it doesn't work with the older yum.
The old package and the old yum work fine together. (As one would expect.)

Nothing is wrong with the old y-m-p, except it doesn't work with newer yum. 

And also, nothing is really wrong with the new package, except if one tries to
upgrade it for some reason one might be in for a surprise.

The issue I'm envisioning where this could be a real world problem is someone
trying to do a yum-based upgrade from FC6 or CentOS 5 to a newer version. For
various reasons this is sometimes best accomplished in chunks of packages rather
than all at once -- and if one happens to upgrade this before upgrading yum,
then yum is hosed. (And doing so might seem like a sensible thing to do, because
one might try to get yum's deps in place before upgrading yum itself, to avoid
the opposite problem that happened a while ago where an upgraded version of yum
would hang if you hadn't first upgraded python-sqlite.)
Comment 3 Jeremy Katz 2007-07-09 09:49:44 EDT
Committed to CVS, will get picked up the next time there's a build
Comment 4 Matthew Miller 2007-07-09 09:55:52 EDT
Sounds good. Thanks.

Note You need to log in before you can comment on or make changes to this bug.