Bug 247463 - Linux hangs on megaraid_sas driver (Raid controller SRCSAS18E)
Linux hangs on megaraid_sas driver (Raid controller SRCSAS18E)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Tom Coughlan
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 10:17 EDT by Vasiliy Kotikov
Modified: 2012-07-20 18:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-20 18:19:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of RHEL 5 driver loading... hang (266.17 KB, image/jpeg)
2007-07-09 10:17 EDT, Vasiliy Kotikov
no flags Details

  None (edit)
Description Vasiliy Kotikov 2007-07-09 10:17:47 EDT
Description of problem:
It is not possible to install OS, the system hangs on loading driver of  	Intel®
RAID Controller SRCSAS18E.
In RHEL5Server release notes, the problem with megaraid driver was mentioned "
driver must be set to operate in "Mass Storage" emulation mode", but the problem
appeared to find this <emulation>. There is no such thing in properties, see
http://www.intel.com/design/servers/raid/srcsas18e/

Version-Release number of selected component (if applicable):
RHEL 5 Server (ISOs downloaded from RHN) with kernel-2.6.18-8.el5

How reproducible:
1 variant: Take server with SAS SCSI disks on SRCSAS18E controller, start the
default installation.
2: I have installed on a "brother" server with another card MegaRAID SAS 8408E 
http://www.lsi.com/storage_home/products_home/internal_raid/megaraid_sas/megaraid_sas_8408e/index.html?remote=1&locale=EN
and after successful install of OS, HDD was moved to the server with the card
SRCSAS18E. (see attached picture)
3: ... I compiled a driver from sources, replaced the megaraid_sas driver as
desribed in this artilce
http://www.tuxyturvy.com/blog/index.php?/archives/4-Installing-RHEL4-on-Systems-with-Legacy-Megaraid-Drivers.html
and tried again => same result - it hangs on loading a driver.
Steps to Reproduce:
1.
2.
3.
  
Actual results:
System cannot load megaraid_sas driver.

Expected results:
megasas driver loads successfully on systems with Intel® RAID Controller SRCSAS18E

Additional info:
I do not know what to do... Intel did not release the driver for RHEL5 only for
RHEL4 (BTW: kernel goes to panic on loading driver of this controller...)
Comment 1 Vasiliy Kotikov 2007-07-09 10:17:48 EDT
Created attachment 158773 [details]
screen shot of RHEL 5 driver loading... hang
Comment 3 bo yang 2010-02-22 09:18:11 EST
You are using very old driver Version 3.05.  Can you try 4.x driver?

Thx
Comment 4 Tom Coughlan 2012-07-20 18:19:46 EDT
No reply. Assuming this is resolved. Closing.

Note You need to log in before you can comment on or make changes to this bug.