Bug 247479 - Bugzilla does not allow to set flags when filing new bug
Bugzilla does not allow to set flags when filing new bug
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
2.18
All Linux
high Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 11:23 EDT by Jan Pazdziora
Modified: 2013-06-23 22:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 13:19:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2007-07-09 11:23:55 EDT
Description of problem:

When I'm filing new bug, the "Flags" section is not shown.

Version-Release number of selected component (if applicable):

2.18

How reproducible:

Deterministic.

Steps to Reproduce:
1. Hit "New", select for example "Red Hat Network Satellite".
2. Fill your bug report.
3. Look for a place to set your flags.
  
Actual results:

There is none.

Expected results:

It should be possible to set flags while filing the bug.

Additional info:

Observe that the "Blocks" field is available (that's what we've used for
tracking bugs before flags).

Not being able to enter flags while filing the bug causes at least three problems:

- It takes more time for the reporter to wait for the bug to get filed and then
scroll down and change the flags.
- It generates extra emails from bugzilla.
- Because reporters do not see the way to set the flags, they do not set them
and the bugs get lost off everyone's radar.

Maybe this is configurable on product's level?
Comment 1 David Lawrence 2007-08-08 16:29:56 EDT
Unfortunately flags are filtered by product and component normally, although
some flags can be set to __Any__ component which would be doable for the
enter_bug.cgi page. That would leave out any that are specific to component
though. Another idea is we could also have a second screen that shows the flags
for the product/component combination that was chosen that could be set at that
time.
Comment 2 David Lawrence 2008-02-14 13:19:55 EST
This feature will be available in the next release of Red Hat Bugzilla.
Hopefully in the next 3-4 months.
Comment 3 Jan Pazdziora 2008-08-19 06:13:56 EDT
Confirming, the flags are there in the bugzilla version 3.2, now deployed.

Note You need to log in before you can comment on or make changes to this bug.