Bug 247480 - can't get IP through dhcp with pxe/kickstart install
Summary: can't get IP through dhcp with pxe/kickstart install
Status: CLOSED DUPLICATE of bug 241783
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-09 15:25 UTC by Need Real Name
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 15:22:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2007-07-09 15:25:50 UTC
Description of problem:
Try to install thinkpad T60W through pxe/kickstart.
dhcp does not work and it could not get an IP address

Version-Release number of selected component (if applicable):
F7, both i386 and x86_64
tried FC6 and it worked fine on the same laptop.

Hardware is think t60w, ethernet card is:
02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controller


How reproducible:
always

Steps to Reproduce:
1. pxe boot and choose kickstart install
2. dhcp and load pxelinux.0
3. can't mount nfs, "alt-f3" shows:
   "sending dhcp request through device eth0
    DHCPDISCOVER on eth0 to 25.255.255.255 port 67 interval 4
    ...
    ...
    DHCPv4 eth0 TIMED OUT
    doing kickstart... setting it up
    ...

  
Actual results:
failed to install

Expected results:
install can go through


Additional info:

Comment 1 Chris Adams 2007-07-10 21:22:07 UTC
I am seeing this same behavior.  I have a server someone in the office put
together, starting with a SuperMicro bare-bones system; the NICs are Intel
Corporation 82547GI Gigabit Ethernet Controller.  I am loading a kickstart via
NFS, so it goes something like:

- PXE boot does DHCP request (works)
- PXE loads kernel with command line to fetch kickstart config via NFS
- kernel/initrd load and run, starting anaconda
- anaconda does DHCP request for fetching kickstart (works)
- kickstart just has "network --hostname blah.hiwaay.net"
- anaconda does DHCP request again to use for install - this fails

I have PXE/kickstarted another F7 box, but it has e100 NICs, not e1000.  Is this
an anaconda bug or a kernel bug?

Comment 2 Chris Adams 2007-07-10 23:51:43 UTC
This is probably a dupe of
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=241783

Comment 3 Chris Adams 2007-07-11 14:04:01 UTC
This is a duplicate of 241783.  I grabbed the latest e1000 driver from Intel,
built the module for the F7 i586 kernel, and rebuild the initrd.img with the
updated e1000 module, and now I can kickstart the system.

Comment 4 David Cantrell 2007-07-19 15:22:05 UTC

*** This bug has been marked as a duplicate of 241783 ***


Note You need to log in before you can comment on or make changes to this bug.