Bug 247494 - Eclipse 3.2.2 performs very badly
Eclipse 3.2.2 performs very badly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Konrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 12:29 EDT by aldo furlan
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 11:13:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Disk drive layout - mount list - PROCINFO (5.08 KB, text/plain)
2007-07-09 12:29 EDT, aldo furlan
no flags Details
Test requested by Andrew (2.82 MB, text/plain)
2007-07-13 18:29 EDT, aldo furlan
no flags Details

  None (edit)
Description aldo furlan 2007-07-09 12:29:39 EDT
Description of problem:

I upgraded from Fedora 6 to F7 64 bits on my acer Aspire 5101 (Amd Turion 64 2.0
Ghz - ram: 1,5 GB - 120GB PATA HDD - OS: Windows XP & Fedora 7 - see attachment).
Eclipse take "minutes" to start, and then respond very slowly to keyboard keyins.
With Fedora 6 it was fast (enougth)!
Slow performance on another laptop with Intel p4 2.0Ghz - 500MB ram Fedora 7 32
bits (complete new install).
My old Dell PIII 800Mhz is 10-100 times faster.


Version-Release number of selected component (if applicable):
Fedora 7 updated today.
Eclipse 3.2.2 update today.

How reproducible:
Always only locally (I suppose).

Steps to Reproduce:
1. Not applicable.
Comment 1 aldo furlan 2007-07-09 12:29:40 EDT
Created attachment 158782 [details]
Disk drive layout - mount list - PROCINFO
Comment 2 Andrew Overholt 2007-07-13 10:49:50 EDT
This is really hard to diagnose.  I honestly can't think of what would have
caused this.  Can you try this:

$ su -
<type in root password>
# gcj-dbtool -l `gcj-dbtool -p /usr/lib`
# gcj-dbtool -l `gcj-dbtool -p /usr/lib64`

and give us the results?  Thanks.
Comment 3 aldo furlan 2007-07-13 11:20:57 EDT
I am sorry Andrew, but in desperation I am  reinstalling Fedora 7, believing
that the problem was due to UPGRADING from F6.

In fact I could not update gcc lib because gpp was not proper set, ad a lot of
other programs were not converted to F7 version.

When the system, I think late today, will be running newly I will re-execute
Eclipse and will inform you about the results.

I installed Eclipse version 3.3 under windows in the same notebook and it take
no more than 10 seconds to start.

Are you planning an upgrade to 3.3 under Fedora?

Thanks.
                          Aldo Furlan

Comment 4 Andrew Overholt 2007-07-13 11:23:03 EDT
I'm sorry to hear that your upgrade didn't go so well.  Hopefully a fresh
install will fix it for you.  Note that under Windows you're using the
proprietary Sun VM (I assume) so startup time will not be an apples to apples
comparison with the gcj-compiled Eclipse we ship by default in Fedora.  Also,
Eclipse isn't the exact same on both platforms.

We will move to 3.3 for Fedora 8.  It is almost ready, actually.
Comment 5 aldo furlan 2007-07-13 18:26:57 EDT
Hi Andrew. I did a F7 fresh install and all seems ok. The start of Eclipse takes
less than 10 seconds; so the problem seem has been in UPGRADING from F6 to F7.

Many thanks for your informations.

You can close the bug. 
I try to include for completeness the test you requested.

Thanks. 
                       Aldo
Comment 6 aldo furlan 2007-07-13 18:29:57 EDT
Created attachment 159250 [details]
Test requested by Andrew

Test requested early by Andrew.

Note You need to log in before you can comment on or make changes to this bug.