Bug 247495 - update fails for libupnp because of vlc dependency of libupnp.so.2
update fails for libupnp because of vlc dependency of libupnp.so.2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libupnp (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Eric Tanguy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 12:31 EDT by Philip Goisman
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 12:35:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Goisman 2007-07-09 12:31:15 EDT
Description of problem:
vlc (vlc-0.8.6a-4.fc6) requires libupnp.so.2
The update wants to install libupnp.so.3 with an update of ushare.
I need vlc for video.  So removing vlc kills my video.

Version-Release number of selected component (if applicable):
FC6

How reproducible:
With vlc and libupnp.so.2 installed try a yum update.  You'll get an update
conflict.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
update conflict

Expected results:
update of libupnp.so.3 will also update vlc

Additional info:
I can exclude updates for ushare and libupnp, but I'd rather get all updates to
include an update for vlc.
Comment 1 Eric Tanguy 2007-07-09 12:35:35 EDT
vlc-0.8.6c-2.lvn7 requires libupnp.so.3 so please update vlc from livna.
Comment 2 Philip Goisman 2007-07-09 16:00:33 EDT
I would have thought a fc6 component would require a fc6 update.  Why does the
livna component replace the fc6 component, i.e.,vlc-0.8.6c-2.lvn7 replace
vlc-0.8.6a-4.fc6?  This substitution causes the following problem:

Error: Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs

faad2-2.5-2.fc6 is presently installed.

In the past it has been reported livna packages may be incompatible with some 
fc packages.  Why can't fc update their own package?
Comment 3 Eric Tanguy 2007-07-09 16:27:27 EDT
Sorry you are right. I made a confusion between FC-6 and F-7. But where this vlc
package come from ?? Please use packages from livna for FC-6 you will find
vlc-0.8.6c-2.lvn6.i386.rpm. Please fill a bug against the vlc package if needed
and use usual repo before fill in a bug.
Comment 4 Philip Goisman 2007-07-09 18:30:46 EDT
Actually, I made a mistake.  Sorry for the confusion.  The vlc package I used
came from freshrpms.  I assumed - incorrectly - that an extension of fc6 meant
it was a fc component.  I'll have to check out how to file a bug report to
freshrpms.

Sorry again for wasting your time.  Thanks for the updates.

Note You need to log in before you can comment on or make changes to this bug.