Bug 247497 - hddtemp giving false readings?
hddtemp giving false readings?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hddtemp (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 12:43 EDT by Brad
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 15:48:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad 2007-07-09 12:43:20 EDT
Description of problem: hddtemp giving false readings?


Version-Release number of selected component (if applicable):
0.3-0.11.beta15.fc7@i386

How reproducible:hddtemp /dev/sda


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Very high temperature reported (58-65C), drive is cool to the touch.

Expected results:
Normal temperature reported (28-34C)


Additional info: The drive is cool to the touch, not even warm. I had assumed it
was just a drive going bad, but the hdparm -tT tests are fine. Drive appears to
be fine after a week(?) of heavy use (tried to push it into dying). At least one
other person is seeing a problem:
http://forums.fedoraforum.org/forum/showthread.php?t=160265&highlight=hddtemp
I suspect that this is a conflict of some sort. It is acting like when there is
a temperature increase it adds the increase to the total instead of calculating
a new total. 

[herb@localhost ~]$ hddtemp /dev/sda
/dev/sda: WDC WD2500JB-00GVC0: 60°C

This same hardware was running FC5 until recently without issue. This is a pata
drive and there is also a sata drive in system (temperature readings normal).
Case(33C) and other temps are all right where they have been. The PSU voltages
are all normal.
Comment 1 Ville Skyttä 2007-07-09 13:36:33 EDT
Interesting.  The first hunch is a Fahrenheit/Celsius issue but that's probably
not the case; 60°F ~ 15°C would be susceptibly low.

Have you checked what smartctl has to say about it, especially in the vendor
specific SMART attributes section?  As root:
    /usr/sbin/smartctl -a /dev/sda | grep -i temperature
Comment 2 Brad 2007-07-09 14:00:34 EDT
No, I had not (not a clue really). But here it is(translation please):

[root@localhost ~]# /usr/sbin/smartctl -a /dev/sda | grep -i temperature
194 Temperature_Celsius     0x0022   090   080   000    Old_age   Always       -
      60
[root@localhost ~]# hddtemp /dev/sda
/dev/sda: WDC WD2500JB-00GVC0: 60°C
[root@localhost ~]# 




The 
Comment 3 Ville Skyttä 2007-07-09 14:50:08 EDT
Run the command without the grep to see column headings for the values reported
by smartctl.  That was just to verify that smartctl and hddtemp see the same
value, and they do, 60.  If the drive reports such values, I'm not sure there's
much hddtemp can/should do about it.  Have you got different values earlier from
the drive, or has it always reported as high values as now?
Comment 4 Brad 2007-07-09 15:31:27 EDT
No, in Fc5 the values would run from 28-34C.

I guess the assessment is that it is probably a sensor failure on the drive
somehow? I am assuming that regardless of whose fault it is, the 60C reading is
incorrect, based upon cool to touch and the drive seems to be functionally ok.
Still makes me nervous.

Thanks for your assistance.

Lazlow
Comment 5 Brad 2007-07-09 15:36:22 EDT
Apparently this is a known issue with WD drives.

http://www.lavalys.com/forum/index.php?showtopic=1372&st=20

Sorry about the waste of time.
Comment 6 Ville Skyttä 2007-07-09 15:48:08 EDT
NP, thanks for the feedback.

Note You need to log in before you can comment on or make changes to this bug.