Bug 247529 - Kernel source fails to compile modules
Kernel source fails to compile modules
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Jason Baron
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 15:11 EDT by frank fisher
Modified: 2013-03-06 00:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 14:16:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description frank fisher 2007-07-09 15:11:57 EDT
Description of problem:
Latest kernel source fails to make, therefore cannot generate anti virus modules
for it.

Version-Release number of selected component (if applicable):
2.6.9-55.0.2

How reproducible:
every time

Steps to Reproduce:
1.up2date get-source kernel
2.cd /usr/src/<wherever>
3.make mrproper, make modules or whatever you choose
  
Actual results:
errors about various components

Expected results:
compiled modules

Additional info:
compile worked fine for -5, and -55 but not -55.0.2
Comment 1 Jason Baron 2007-09-27 11:20:01 EDT
hmmm, this seems to work fine for me on 55.0.2 are you sure you did 'make
oldconfig'? What is the exact error you are getting?
Comment 2 frank fisher 2007-10-01 06:10:43 EDT
Hi, after a few more machines tested it may be more of an inconsistency between
installs and updates.  The procedure for compile seems totally different after
an update to before, but all I had to go on at the time was a lot of machines
with different kernels installed.  It turns out none of them had been updated,
just installed at different kernel stages over many months.  Running the updates
seemed to break the instructions that came with the AV, but digging deeper into
google found a longer winded method that worked eventually.
Comment 3 Jason Baron 2007-10-01 14:16:32 EDT
ok, i'm closing this as not a bug. if you have any specific errors, including
with documentation, please feel free to re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.