Bug 247531 - Feature: plugin to gather initial ramdisk scripts
Summary: Feature: plugin to gather initial ramdisk scripts
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Adam Stokes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-09 19:30 UTC by Chris Evich
Modified: 2008-03-04 00:15 UTC (History)
0 users

Fixed In Version: 1.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 00:15:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sos plugin (1.03 KB, text/plain)
2007-07-09 19:30 UTC, Chris Evich
no flags Details

Description Chris Evich 2007-07-09 19:30:03 UTC
Description of problem:
Sometimes mkinitrd breaks or the system won't boot with a newly installed kernel
due to third-party module dependency breakage.  This plugin extracts the init
script from each initial ramdisk built on the system for comparison.  This
script clearly shows which modules are present at boot time and what devices are
being referenced.

Version-Release number of selected component (if applicable):
sos-1.3-1.el5

Comment 1 Chris Evich 2007-07-09 19:30:04 UTC
Created attachment 158799 [details]
sos plugin

Comment 2 Navid Sheikhol-Eslami 2007-07-10 10:10:34 UTC
I have committed this to HEAD under a more generic name of "initrd".

The plugin is currently disabled by default, which means that to be activated it
will be either need to be specified in --onlyplugin or --enableplugin.

-- Navid

Comment 3 Chris Evich 2007-07-10 13:49:43 UTC
Both sound good.  Do default disabled items show up in the ncurses list
automatically or is that another attribute that needs to be set?

Comment 4 Navid Sheikhol-Eslami 2007-07-10 22:07:31 UTC
I would like to divide plugins in:

1. enabled by default (things like general, process, kernel and so forth)
2. disabled by default (plugins that provide specialized info for files/packages
that are normally present on all systems.. like initrd.py)
3. conditionally enabled (the decision whether to load or not is left to the
plugins' checkenabled() return value)

Both disabled and conditional plugins can be enabled by command-line. Also
options can now be set directly in the command-line (-k option), which means
that the ncurses menu could actually go away soon.

-- Navid


Note You need to log in before you can comment on or make changes to this bug.