Bug 247550 - anaconda doesn't create a useful ks.cfg
anaconda doesn't create a useful ks.cfg
Status: CLOSED DUPLICATE of bug 227383
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 17:54 EDT by JB Segal
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 12:41:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JB Segal 2007-07-09 17:54:18 EDT
Description of problem:
auto-generated ks.cfg contains useless package list. I need a real one.

Version-Release number of selected component (if applicable):


How reproducible:
completely

Steps to Reproduce:
1. Install a new RHEL5 system, modifying the list of installed packages by hand.
2. Look at the auto-generated /root/anaconda-ks.cfg, to use in the next install.
  
Actual results:
%packages
@editors


Expected results:
Something more like what I got with RHEL4:
%packages --resolvedeps
@ editors
@ emacs
@ system-tools
@ dialup
@ ftp-server
@ emacs
@ server-cfg
@ development-tools
kernel-smp
-bluez-pin
e2fsprogs
lvm2
-httpd-manual
 . . .


Additional info:
This isn't at all useful for actually reproducing a build using kickstart.

Failing a fix, a good answer for how to correctly generate that section of the
ks.cfg after a system's installed would be really useful.
Comment 1 Chris Lumens 2007-07-10 12:41:50 EDT

*** This bug has been marked as a duplicate of 227383 ***

Note You need to log in before you can comment on or make changes to this bug.