Bug 247597 - segfault when using pdf2ps
segfault when using pdf2ps
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-07-10 05:38 EDT by Andrew Clayton
Modified: 2008-05-14 11:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: ghostscript-8.61-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 11:57:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Clayton 2007-07-10 05:38:53 EDT
Description of problem:

When trying to convert

http://www.gosecure.ca/SecInfo/library/WebApplication/OWASPGuide2.0.1.pdf

to a postscript file with pdf2ps

I get a segmentation fault.

pdftops (from poppler-utils-0.5.4-7.fc7.x86_64) works fine.


Version-Release number of selected component (if applicable):

ghostscript-8.15.4-3.fc7.x86_64
ghostscript-8.15.4-3.fc7.i386


How reproducible:

100%


Steps to Reproduce:

1. Download the pdf
2. pdf2ps OWASPGuide2.0.1.pdf owasp.ps
3.
  

Actual results:

Segmentation fault


Expected results:

owasp.ps


Additional info:

System is an AMD64 (running 64bit Fedora 7).
Comment 1 Tim Waugh 2007-07-10 07:22:30 EDT
I couldn't reproduce this on i386 with ghostscript-8.15.4-3.fc7.  Perhaps it's
an problem that only shows up on x86-64.
Comment 2 Andrew Clayton 2007-07-10 08:23:09 EDT
Just tried it on my x86 FC6 machine (ghostscript-8.15.4-1.fc6) and it worked fine.
Comment 3 Hans de Goede 2007-09-19 13:53:21 EDT
I've just tried to reproduce this with rawhide on an x86_64 machine and it works
fine, so I guess the new ghostscript 8.60 in rawhide
(ghostscript-8.60-2.fc8.x86_64) has this fixed.
Comment 4 Bug Zapper 2008-05-14 09:29:20 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Andrew Clayton 2008-05-14 11:57:43 EDT
Oh, I forgot about this, yes this works now... Fedora 8.

Note You need to log in before you can comment on or make changes to this bug.