This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 247613 - desktop-file-install can't handle -m664, --mode 664 is ok
desktop-file-install can't handle -m664, --mode 664 is ok
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: desktop-file-utils (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-10 09:09 EDT by Doncho N. Gunchev
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 10:38:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Doncho N. Gunchev 2007-07-10 09:09:47 EDT
Description of problem:
The command 'desktop-file-install --mode 664 ...' works, 
while 'desktop-file-install -m664 ...' results in:
Unknown option ""

Version-Release number of selected component (if applicable):
desktop-file-utils-0.12-4.fc7

How reproducible:
always

  
Expected results:
-m644 should be equivalent to --mode 664

Additional info:
$ desktop-file-install --help-all
...
  -m, --mode                      Set the given permissions on the destination 
file.
...
Comment 1 Matthias Clasen 2007-10-02 10:38:50 EDT
You can use -m 644 or --mode 644 or --mode=644. Only -m644 does not work.
Comment 2 Doncho N. Gunchev 2007-10-03 03:26:59 EDT
I see, 10x for the info and sorry.

There are .spec files (at least one) that use exactly -m644, because I 
copy-pasted it from someone else's...

Note You need to log in before you can comment on or make changes to this bug.