Bug 247636 - GCJ don't find org.eclipse.pde.internal.build.BuildScriptGenerator
Summary: GCJ don't find org.eclipse.pde.internal.build.BuildScriptGenerator
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.5.0-gcj   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-10 15:58 UTC by Alphonse Van Assche
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-09 21:32:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alphonse Van Assche 2007-07-10 15:58:07 UTC
Description of problem:
When I build a Eclipse plugin for 3.3 with the Sun JVM there isn't any problem
but when I try it with GCJ the Eclipse builder don't find
org.eclipse.pde.internal.build.BuildScriptGenerator class and fail with this
message:

BUILD FAILED
/usr/share/eclipse/plugins/org.eclipse.pde.build/scripts/build.xml:24:
The following error occurred while executing this line:
/usr/share/eclipse/plugins/org.eclipse.pde.build/scripts/build.xml:64:
The following error occurred while executing this line:
/usr/share/eclipse/plugins/org.eclipse.pde.build/templates/package-build/customTargets.xml:17:
The following error occurred while executing this line:
/usr/share/eclipse/plugins/org.eclipse.pde.build_3.3.0.v20070612/scripts/genericTargets.xml:85:
Could not create type eclipse.buildScript due to
java.lang.NoClassDefFoundError:
org.eclipse.pde.internal.build.BuildScriptGenerator

Version-Release number of selected component (if applicable):
java-1.5.0-gcj-1.5.0.0-14.fc7
libgcj-4.1.2-12
eclipse-pde-3.3.0-1.fc8 (build here form the source repo)

How reproducible:
building any Eclipse package that use the Eclipse builder like eclipse-mylar and
 eclipse-changelog packages.

Additional info:
$ locate org.eclipse.pde | grep jar.db
/usr/lib/gcj/eclipse/org.eclipse.pde.core_3.3.0.v20070608-1300.jar.db
/usr/lib/gcj/eclipse/org.eclipse.pde.junit.runtime_3.3.0.v20070608-1300.jar.db
/usr/lib/gcj/eclipse/org.eclipse.pde.runtime_3.3.0.v20070608-1300.jar.db
/usr/lib/gcj/eclipse/org.eclipse.pde.ui.templates_3.3.0.v20070608-1300.jar.db
/usr/lib/gcj/eclipse/org.eclipse.pde.ui_3.3.0.v20070608-1300.jar.db
/usr/lib/gcj/eclipse/org.eclipse.pde_3.3.0.v20070608-1300.jar.db

$ locate org.eclipse.pde | grep .jar | grep /usr/share
/usr/share/eclipse/plugins/org.eclipse.pde.build.nls.fr_3.2.1.v200609270227.jar
/usr/share/eclipse/plugins/org.eclipse.pde.core.nls.fr_3.2.1.v200609270227.jar
/usr/share/eclipse/plugins/org.eclipse.pde.core_3.3.0.v20070608-1300.jar
/usr/share/eclipse/plugins/org.eclipse.pde.doc.user.nls.fr_3.2.1.v200609270227.jar
/usr/share/eclipse/plugins/org.eclipse.pde.junit.runtime.nls.fr_3.2.0.v200609270227.jar
/usr/share/eclipse/plugins/org.eclipse.pde.junit.runtime_3.3.0.v20070608-1300.jar
/usr/share/eclipse/plugins/org.eclipse.pde.nls.fr_3.2.1.v200609270227.jar
/usr/share/eclipse/plugins/org.eclipse.pde.runtime.nls.fr_3.2.0.v200609270227.jar
/usr/share/eclipse/plugins/org.eclipse.pde.runtime_3.3.0.v20070608-1300.jar
/usr/share/eclipse/plugins/org.eclipse.pde.source.nls.fr_3.2.1.v200609270227.jar
/usr/share/eclipse/plugins/org.eclipse.pde.ui.nls.fr_3.2.1.v200609270227.jar
/usr/share/eclipse/plugins/org.eclipse.pde.ui.templates_3.3.0.v20070608-1300.jar
/usr/share/eclipse/plugins/org.eclipse.pde.ui_3.3.0.v20070608-1300.jar
/usr/share/eclipse/plugins/org.eclipse.pde_3.3.0.v20070608-1300.jar
/usr/share/eclipse/plugins/org.eclipse.pde.build_3.3.0.v20070612/pdebuild.jar
/usr/share/eclipse/plugins/org.eclipse.pde.build_3.3.0.v20070612/lib/pdebuild-an

Comment 1 Alphonse Van Assche 2007-07-10 16:12:08 UTC
How reproducible:
checkout eclipse/devel
make i386 
Take 5 or 10 coffee cup :-) 
checkout eclipse-mylar/devel
make i386

the last make should be fail with the above message.



Comment 2 Andrew Overholt 2007-08-09 19:35:19 UTC
Hmm, I didn't realize mylar wouldn't build ATM.  I'm actually waiting on
upstream to sort out a tagging issue before bumping to 2.0 final:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=198579

Comment 3 Ben Konrath 2007-08-09 21:32:10 UTC
I just updated mylar/mylyn to 2.0.0 and the build is working on rawhide. I'll
commit the changes tomorrow. Closing bug.


Note You need to log in before you can comment on or make changes to this bug.