Bug 247640 - kernel-xen-2.6 FC-6 branch needed
kernel-xen-2.6 FC-6 branch needed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-xen-2.6 (Show other bugs)
6
All Linux
high Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-10 12:30 EDT by Eduardo Habkost
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 10:02:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
katzj: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Eduardo Habkost 2007-07-10 12:30:40 EDT
Package Change Request
======================
Package Name: kernel-xen-2.6
New Branches: FC-6


The kernel-xen-2.6 package was created after the FC-6 release, because the 
rebasing speed of the non-xen kernel was faster than are able to rebase the 
xen patches. Recently FC-6 kernel-xen updates were made using the same source 
package that is used for the non-xen kernel. However, the FC-6 kernel was 
rebased to 2.6.22 and kernel-xen can't use this kernel version right now. We 
need kernel/kernel-xen to be split on FC-6, also.

It would be useful if the new kernel-xen-2.6/FC-6 branch is created as a copy 
of kernel/FC-6, keeping the package history. If this is not possible, 
importing kernel-2.6.20-1.2962.fc6 source RPM into the branch would be enough.
Comment 1 Warren Togami 2007-07-12 13:11:20 EDT
This is internal CVS.   Reassigning.
Comment 2 Eduardo Habkost 2007-07-12 13:22:21 EDT
A question: after the kernel-xen-2.6 FC-6 branch is created, will the FC-6 
update system work when I try to release an update to this package, even if a 
kernel-xen-2.6 was never released before? (kernel-xen binary packages were 
released before, but they were built from the kernel source rpm in the past)
Comment 3 Jeremy Katz 2007-07-16 10:02:08 EDT
That should work with the update system.  And the branch should be done with the
bits from FC-6 kernel copied over.

Note You need to log in before you can comment on or make changes to this bug.