Bug 247730 - building from src.rpm deletes some source files from ~/rpmbuild/SOURCES/
building from src.rpm deletes some source files from ~/rpmbuild/SOURCES/
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 00:19 EDT by Andrew Duggan
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel spec r1.3266
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 17:23:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Duggan 2007-07-11 00:19:11 EDT
Description of problem:

recent kernel-2.6.spec files delete kernel-%{version}-*.config files from the
SOURCES directory, preventing rpmbuild -ba --target $arch kernel-2.6.spec from
finishing

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3255.fc7.src.rpm
kernel-2.6.22-2.fc7.src.rpm


How reproducible:

Always
Steps to Reproduce:
1.rpmbuild -ba --target i686 kernel-2.6.spec
2.
3.
  
Actual results:
$RPM_SOURCE_DIR/kernel-%{version}-*.config are deleted

Expected results:
rm -f $RPM_SOURCE_DIR/kernel-%{version}-*.config should be retained

Additional info:

likely back-to-back rpmbuild -bb would fail also as files listed in the SPEC as
SOURCEn:  would be deleted.

rm -f $RPM_SOURCE_DIR/kernel-%{version}-*.config
Comment 1 Christopher Brown 2007-09-17 17:23:02 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

For compiling your own kernel, you should follow the instructions located at:

http://fedoraproject.org/wiki/Docs/CustomKernel

If this renders you still unable to compile a kernel, please re-open this bug
however I am closing as I cannot replicate and there has been no activity since
the initial report over two months ago.

Regards
Chris
Comment 2 Andrew Duggan 2007-09-17 20:50:08 EDT
FWIW, while it's not a bug now,  it WAS a bug for those two revisions of the
kernel-2.6.spec.  I've been rebuilding and customizing kernel builds (via rpm
(since I like everything under the control of RPM) since FC2 way, way, way
before there was any good documentation. 

Sorry to put you through the trouble, since they fixed it the same day (as it
turns out), and I then forgot about it. It was during the time when 
- the spec file was being restructured, 
- the naming scheme for the kernel package version was being changed 

During that time they were changing the way .config files are handled (I think
they meant to delete the ones in the build root (which is correct) but instead
accidentally had the rpm source directory specified instead.  

If you go to
http://cvs.fedoraproject.org/viewcvs/rpms/kernel/F-7/kernel-2.6.spec?rev=1.3255&view=markup
you will see this line 

rm -f $RPM_SOURCE_DIR/kernel-%{version}-*.config

(which was the problem)

If you look at revision 1.3266

you will see that the comment

Revision 1.3266  - (view) (download) (annotate) - [select for diffs]
Wed Jul 11 14:19:20 2007 UTC (2 months, 1 week ago) by jwilson
Branch: MAIN
Changes since 1.3265: +1 -2 lines
Diff to previous 1.3265

Remove config removal line here too, busts rpmbuild -ba

The actual change here
http://cvs.fedoraproject.org/viewcvs/rpms/kernel/F-7/kernel-2.6.spec?r1=1.3265&r2=1.3266

So while it doesn't really matter that much, it's really should have been closed
with "CURRENTRELEASE" not "NOTABUG", it just that the current release that fixed
it was 2 months ago (and FWIW later the same day I opened the BUG).

This report was opened at Jul 11 2007 00:19 EST  and the fix was put into CVS at
Jul 11 14:19:20 2007 UTC almost exactly 10 hours later. 

I'm not a BZ expert, so I don't know if the fixed in version would be 1.3266 or
if they want the full kernel version src rpm name.
Comment 3 Christopher Brown 2007-09-18 04:43:42 EDT
Ah right, thanks for the info Andrew. I'm changing the closed status to reflect
that then.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.