Bug 247762 - The ISO contains an empty doc/ directory
Summary: The ISO contains an empty doc/ directory
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer   
(Show other bugs)
Version: 500
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Brandon Perkins
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-11 10:56 UTC by Jan Pazdziora
Modified: 2007-08-29 15:30 UTC (History)
2 users (show)

Fixed In Version: sat501
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 15:30:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Pazdziora 2007-07-11 10:56:40 UTC
Description of problem:

The ISO contains an empty doc/ directory. It should either be removed, or filled
with content. ;-)

Version-Release number of selected component (if applicable):

ISO 5.0.0-43

How reproducible:

Seems to be empty any time I look.

Steps to Reproduce:
1. mkdir x && mount -o loop,ro
rhn-satellite-5.0.0-43-redhat-linux-as-i386-4-embedded-oracle.iso x
2. ls -la x/doc*
  
Actual results:

# ls -la x/doc*
total 4
dr-xr-xr-x  2 root root 2048 Jun 21 14:29 .
dr-xr-xr-x  7 root root 2048 Jun 21 14:32 ..
#

Expected results:

Some content. Or no directory at all.

Additional info:

Comment 3 Brandon Perkins 2007-07-23 22:54:01 UTC
Resolved for all future ISO builds (as this code is not branched and always
called from the HEAD revision):

Checking in build-functions.sh;
/cvs/rhn/rhn/build-functions.sh,v  <--  build-functions.sh
new revision: 1.59; previous revision: 1.58
done


Comment 4 John Ha 2007-08-01 02:07:56 UTC
If this doesn't significantly impact the usage of the product (seeing that it
was an empty directory anyway), does it require a release note? Let me know
either way.

Comment 5 Clifford Perry 2007-08-01 12:50:44 UTC
No release note needed here. 


Comment 6 Brandon Perkins 2007-08-02 20:12:36 UTC
ON_QA

Comment 7 Corey Welton 2007-08-03 14:53:13 UTC
QA Verified; directory no longer exists:

[root@rlx-0-12 iso]# pwd
/root/iso
[root@rlx-0-12 iso]# ls -alF /root/iso/docs
ls: /root/iso/docs: No such file or directory


Comment 8 Corey Welton 2007-08-22 21:06:48 UTC
RELEASE_PENDING


Note You need to log in before you can comment on or make changes to this bug.