This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 247763 - anaconda forgets the NFS part of /etc/fstab when upgrading FC6->F7
anaconda forgets the NFS part of /etc/fstab when upgrading FC6->F7
Status: CLOSED DUPLICATE of bug 242073
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 07:00 EDT by Joachim Backes
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 10:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2007-07-11 07:00:31 EDT
Description of problem: Having a /etc/fstab with local entries and a NFS part
(for remote mountes directories). When upgrading from FC6 to F7, the NFS part is
lost, that means in F7, the NFS entries are missing in /etc/fstab:

Fc6-/etc/fstab:
===============

LABEL=/                 /                       ext3    defaults        1 1
LABEL=SYSTEM_BACKUP     /SYSTEM_BACKUP          ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
LABEL=disk3             /disk3                  ext3    defaults        1 2
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=tmp               /tmp                    ext3    defaults        1 2
LABEL=local             /usr/local              ext3    defaults        1 2
LABEL=swap              swap                    swap    defaults        0 0
#
aixf3:/gu1              /gu1                    nfs     rw,rsize=8192,wsize=8192
       0 0
aixf3:/gu2              /gu2                    nfs     rw,rsize=8192,wsize=8192
       0 0
aixf3:/gu3              /gu3                    nfs     rw,rsize=8192,wsize=8192
       0 0
aixf3:/gu4              /gu4                    nfs     rw,rsize=8192,wsize=8192
       0 0
nas1:/nfs/scratch       /scratch                nfs     rw,rsize=8192,wsize=8192
       0 0

F7-/etc/fstab
=============
LABEL=/                 /                       ext3    defaults        1 1
LABEL=SYSTEM_BACKUP     /SYSTEM_BACKUP          ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
LABEL=disk3             /disk3                  ext3    defaults        1 2
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=tmp               /tmp                    ext3    defaults        1 2
LABEL=local             /usr/local              ext3    defaults        1 2
LABEL=swap              swap                    swap    defaults        0 0


Version-Release number of selected component (if applicable):


How reproducible:

Did not try


Steps to Reproduce:
1.Update from FC6 to F7 with such a /etc/fstab
2.
3.
  
Actual results:
The nfs part are missing after update, I have to add them by hand

Expected results:
the complete /etc/fstab is adopted

Additional info:
Comment 1 Chris Lumens 2007-07-11 10:03:00 EDT

*** This bug has been marked as a duplicate of 242073 ***

Note You need to log in before you can comment on or make changes to this bug.