Fedora Account System
Red Hat Associate
Red Hat Customer
+++ This bug was initially created as a clone of Bug #2460065 +++ When attempting to start nghttpx, the service successfully launches but then times out, terminating the service, resulting in an endless restart loop. Systemd service is Type=notify - does this need changing? Apr 21 13:19:22 instance systemd[1]: Starting nghttpx.service - HTTP/2 proxy... Apr 21 13:19:22 instance nghttpx[1780]: 2026-04-21T13:19:22.502Z 1780 1780 ed612864 NOTICE (shrpx.cc:3274) Loading configuration from /etc/nghttpx/nghttpx.conf Apr 21 13:19:22 instance nghttpx[1780]: 2026-04-21T13:19:22.502Z 1780 1780 ed612864 NOTICE (shrpx.cc:1467) Worker process [1781] spawned Apr 21 13:19:22 instance nghttpx[1781]: 2026-04-21T13:19:22.504Z 1780 1781 ed612864 NOTICE (shrpx_worker.cc:892) Listening on 127.0.0.1:3000 Apr 21 13:19:22 instance nghttpx[1781]: 2026-04-21T13:19:22.504Z 1780 1781 ed612864 NOTICE (shrpx_connection_handler.cc:306) [LISTEN:0x0000aaaaf71ed380] Created worker thread #0 Apr 21 13:19:22 instance nghttpx[1780]: 2026-04-21T13:19:22.505Z 1780 1780 ed612864 NOTICE (shrpx.cc:1240) Worker process pid=1781 is ready Apr 21 13:20:07 instance systemd[1]: nghttpx.service: start operation timed out. Terminating. Apr 21 13:20:07 instance nghttpx[1781]: 2026-04-21T13:20:07.725Z 1780 1781 ed612864 NOTICE (shrpx_worker_process.cc:126) Graceful shutdown signal received Apr 21 13:20:07 instance nghttpx[1781]: 2026-04-21T13:20:07.725Z 1780 1781 a17e5c9a NOTICE (shrpx_worker.cc:530) [WORKER:0x0000aaaaf721b1e0] Graceful shutdown commencing Apr 21 13:20:07 instance nghttpx[1781]: 2026-04-21T13:20:07.726Z 1780 1781 ed612864 NOTICE (shrpx.cc:1420) Worker process shutting down momentarily Apr 21 13:20:07 instance nghttpx[1780]: 2026-04-21T13:20:07.727Z 1780 1780 ed612864 NOTICE (shrpx_log.cc:837) Worker process: [1781] exited normally with status 0x00000000; exit status 0 Apr 21 13:20:07 instance nghttpx[1780]: 2026-04-21T13:20:07.727Z 1780 1780 ed612864 NOTICE (shrpx.cc:4945) Shutdown momentarily Apr 21 13:20:07 instance systemd[1]: nghttpx.service: Failed with result 'timeout'. Apr 21 13:20:07 instance systemd[1]: Failed to start nghttpx.service - HTTP/2 proxy. Apr 21 13:20:07 instance systemd[1]: nghttpx.service: Scheduled restart job, restart counter is at 4. Reproducible: Always Steps to Reproduce: 1. Install nghttpx 2. Create /etc/nghttpx/nghttpx.conf with frontend=127.0.0.1,3000;no-tls 3. sudo systemctl start nghttpx 4. journalctl -u nghttpx.service -f
This bug appears to have been reported against 'rawhide' during the Fedora Linux 45 development cycle. Changing version to 45.