Bug 247807 - Can't go back to "TCP/IP Configuration" screen after choosing "OK" on anaconda
Can't go back to "TCP/IP Configuration" screen after choosing "OK" on anaconda
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 11:10 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 11:37:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (383 bytes, patch)
2007-07-11 11:10 EDT, IBM Bug Proxy
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 35183 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-07-11 11:10:02 EDT
LTC Owner is: lucasgf@br.ibm.com
LTC Originator is: dmfaria@br.ibm.com

Problem description:
When we begin a network installation of the Fedora 7 GA'd, anaconda asks for
network configuration if you choose to manually configure your network. Then you
have just one chance of filling it correctly, because if you want to modify some
configuration after going to the next screen, anaconda doesn't allow you to do
that. So to modify it you will need to reboot the machine and start the process
again.

This is reproducible in any hardware platform.

Steps to reproduce:
1 - netboot your F7GA image
2 - Choose a Language -> English -> OK
3 - Installation Method -> NFS directory -> OK
4 - Networking Device -> eth1 -> OK
5 - Configure TCP/IP -> Select Manual configuration for IPv4 and Automatic for
IPv6 -> OK
6 - Manual TCP/IP Configuration -> Fill the ethernet configuration -> OK
7 - NFS Setup -> back -> You will have to reboot your computer if you want to
manually configure the ethernet again.

After gdb'ing a little bit I could find the root cause. There is some parts of
the manual configuration on the loader code that are mixed with kickstart
installations code. So, when you configure your network for the first time, it
sets up a variable (loaderData->ipinfo_set) indicating that you've done it. This
same variable is used on kickstart installations. Right before asking the user
to configure the network, the loader checks this variable in order to determine
whether or not it should ask the user to do so. Since the loader doesn't want to
ask the user to do anything on a kickstart installation, there is some code to
skip the tcp/ip configuration step if the variable above is set. So, I'm
attaching a simple patch to fix this. The patch will reset this variable
(loaderData->ipinfo_set) if the user presses back during the NFS confguration
step (actually, not only NFS but any network method), thus being able to
reconfigure the network.

Thanks,
Lucas.
Comment 1 IBM Bug Proxy 2007-07-11 11:10:03 EDT
Created attachment 158959 [details]
patch
Comment 2 Chris Lumens 2007-07-11 11:37:03 EDT
Thanks for the patch.  This will be in the next build of anaconda.
Comment 3 IBM Bug Proxy 2007-07-11 14:16:27 EDT
----- Additional Comments From dmfaria@br.ibm.com  2007-07-11 14:10 EDT -------
Yes Lucas! 
Comment 4 IBM Bug Proxy 2007-10-04 16:45:28 EDT
------- Comment From dmfaria@br.ibm.com 2007-10-04 16:42 EDT-------
It is working! I tested the rawhide Fedora from October 03.

There is a small problem, but I think this won't hurt:
When you hit "NFS Setup -> back" it returns to the "Configure TCP/IP" screen
instead of returning to "Manual TCP/IP Configuration" and it selects DHCP for
IPv4 instead of keeping your old choice, "Manual configuration". This is a minor
bug.

I will close this bug as it is fixed! Thanks for the work here!

Note You need to log in before you can comment on or make changes to this bug.