Bug 247861 - Undefined symbol while executing keepass
Summary: Undefined symbol while executing keepass
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: keepassx (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-11 18:54 UTC by Sanjeev Premi
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 4.3.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-14 07:33:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sanjeev Premi 2007-07-11 18:54:35 UTC
Description of problem:


Version-Release number of selected component (if applicable):

[root@piggy Fedora]$ rpm -qa | grep keepass
keepassx-0.2.2-2.fc7


How reproducible: Easily


Steps to Reproduce:
1. Download & install "keepassx-0.2.2-2.fc7.i386.rpm"
2. Execute the command "keepass"
  
Actual results:

[root@piggy Fedora]$ /usr/bin/keepass
/usr/bin/keepass: symbol lookup error: /usr/bin/keepass: undefined symbol:
_ZN9QListData7detach2Ev

Expected results:
Expected to see the KeePass application to launch.

Additional info:
Linux piggy.home.net 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 15:37:31 EDT 2007 i686
i686 i386 GNU/Linux

Comment 1 Aurelien Bompard 2007-07-12 06:26:56 UTC
Thanks for the report. I can't reproduce it here (yet). What's your version of
qt4 ? (output of "rpm -q qt4")

Comment 2 Sanjeev Premi 2007-07-12 13:37:52 UTC
qt4-4.2.3-8.fc7


Comment 3 Sanjeev Premi 2007-07-12 16:11:19 UTC
Taking cue from your response, i upgraded to qt4-4.3.0-2.fc7.

The problem doesn't exist with this version of QT4.

Comment 4 Aurelien Bompard 2007-07-14 07:33:48 UTC
Thanks, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.