Bug 247877 - dm-mirror: spinlock in write_callback has the potential for deadlock
dm-mirror: spinlock in write_callback has the potential for deadlock
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Earl Brassow
Martin Jenner
:
Depends On:
Blocks: 247879 425461
  Show dependency treegraph
 
Reported: 2007-07-11 16:15 EDT by Jonathan Earl Brassow
Modified: 2008-05-21 10:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:46:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2007-07-11 16:15:41 EDT
write_callback is in dm-raid1.c is called when an I/O completes.  It calls
spin_lock(&ms->lock).  Since write_callback could be called from either process
or interrupt context, we need to use spin_lock_irqsave().

This becomes especially important when we want to layer dm-targets that might
call bio_endio from process context.
Comment 1 RHEL Product and Program Management 2007-08-13 10:11:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Don Zickus 2007-12-21 15:17:18 EST
in 2.6.18-62.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 5 errata-xmlrpc 2008-05-21 10:46:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.