Bug 24790 - Glibc resolver leaks UDP sockets
Glibc resolver leaks UDP sockets
Status: CLOSED DUPLICATE of bug 18332
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-23 19:42 EST by Need Real Name
Modified: 2016-11-24 10:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 06:31:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-23 19:42:20 EST
The resolver can leak UDP sockets if the first nameserver in
/etc/resolv.conf is down or invalid and the second is valid.  To test this,
I wrote a sort program that ran gethostbyname in a loop and ran it under
strace and watched the descriptor numbers steadily increase.
Comment 1 Jakub Jelinek 2001-01-24 06:30:25 EST
Do you have latest glibc errata installed?
This looks like duplicate of #18332 which has been fixed in glibc-2.2-12.
Comment 2 Jakub Jelinek 2001-02-12 04:40:46 EST

*** This bug has been marked as a duplicate of 18332 ***

Note You need to log in before you can comment on or make changes to this bug.